Bug 581049 - [abrt] crash in libvirt-0.7.1-15.fc12: Process /usr/sbin/libvirtd was killed by signal 11 (SIGSEGV)
[abrt] crash in libvirt-0.7.1-15.fc12: Process /usr/sbin/libvirtd was killed ...
Status: CLOSED DUPLICATE of bug 554191
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
abrt_hash:489bb68a3d9866b1dbcde6ceb0d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-09 17:50 EDT by Oron Peled
Modified: 2010-05-10 16:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 16:39:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (41.38 KB, text/plain)
2010-04-09 17:50 EDT, Oron Peled
no flags Details

  None (edit)
Description Oron Peled 2010-04-09 17:50:39 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: libvirtd --daemon
component: libvirt
executable: /usr/sbin/libvirtd
kernel: 2.6.32.10-90.fc12.i686.PAE
package: libvirt-0.7.1-15.fc12
rating: 4
reason: Process /usr/sbin/libvirtd was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Create an LXC instance on one host:
    [root@argon ~]# virsh --connect lxc:/// define /etc/libvirt/lxc/vm1_fedora.xml
2. Test local connection (everything is OK):
    [root@argon ~]# virsh --connect lxc:/// start vm1_fedora
    [root@argon ~]# virsh --connect lxc:/// list --all
    [root@argon ~]# virsh --connect lxc:/// console vm1_fedora
3. Try to access remotely (via ssh) from a different host:
    [root@neon ~]# virsh --connect lxc+ssh://argon

Step 3. crash libvirtd on the original host (argon).
Comment 1 Oron Peled 2010-04-09 17:50:45 EDT
Created attachment 405652 [details]
File: backtrace
Comment 2 Oron Peled 2010-04-09 18:09:45 EDT
Just found how to make it NOT crash. Simply use:
    [root@neon ~]# virsh --connect lxc+ssh://argon/
The trailing slash (/) does the trick. Without it the bug is triggered.

1. This is still a bug (IMO).
2. The real culprit is probably the code that calls lxcOpen() -- It is valid for lxcOpen()
    to fail because of bad URI (altough it would be nice for it to be less picky). However
    it is not valid for this to crash libvirtd.
3. I just tried to trigger the crash as normal user. The authentication failure blocked it
    before reaching the buggy code, so it looks like there aren't any security
    implications yet.
Comment 3 Adrian A. Sender 2010-04-19 06:15:44 EDT
I am also having a similar issue with running GFS & rgmanager polling libvirt for a virsh status. After a couple of weeks uptime I am consistently having this same issue. Even though the vm is still running and up rgmanager requires the libvirt daemon to be restarted and rgmanager resource to be started & stopped to put it back in the correct state. It's a real pain..

Process /usr/sbin/libvirtd was killed by signal 6 (SIGABRT)

 Member Name                             ID   Status
 ------ ----                             ---- ------
 core-01_int                                 1 Online, Local, rgmanager
 core-02_int                                 2 Online, rgmanager

 Service Name                   Owner (Last)                   State         
 ------- ----                   ----- ------                   -----         
 vm:blueonyx_01                 core-01_int                    started       
 vm:blueonyx_02                 core-01_int                    started       
 vm:vds-blueonyx_02             (core-02_int)                  failed        
 vm:vds-centos_01               core-01_int                    started       
 vm:vds-centos_02               core-01_int                    started       
 vm:vds-centos_04               (core-02_int)                  failed        
 vm:winxp_01                    core-01_int                    started
Comment 4 Cole Robinson 2010-05-10 16:12:51 EDT
Adrian, doesn't sound like your issue is the same as the original report. Can you run 'gdb libvirtd', reproduce the crash, then enter 'thread apply all bt' and open a new bug? Thanks
Comment 5 Cole Robinson 2010-05-10 16:39:23 EDT
Also, seems there is already another bug tracking this issue.

*** This bug has been marked as a duplicate of bug 554191 ***

Note You need to log in before you can comment on or make changes to this bug.