Bug 58105 - kickstart --device option fails for eth1 specification
kickstart --device option fails for eth1 specification
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-08 12:54 EST by James McDermott
Modified: 2014-08-24 20:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 16:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James McDermott 2002-01-08 12:54:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7-smp-ja i686)

Description of problem:
When setting options for kickstart and trying not to use eth0 as the default
installtion device the --device option is used to specify eth1, unfortunatley
this does not work and the install continues on eth0. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.tried both: network --bootproto dhcp --device eth1 and network --device eth1
--bootproto dhcp
2.write kickstart file and kickstart machine

	

Actual Results:  dhcp request times out

Expected Results:  eth1 should have gotten a valid ip address and started
installing

Additional info:

The documentation for this option is at:
https://www.redhat.com/docs/manuals/linux/RHL-7.1-Manual/custom-guide/s1-kickstart2-options.html

Look under networking. We also tried the 7.2 options just to see if perhaps the
setup had been documented inaccuratley to no avail.
Comment 1 Brent Fox 2002-01-08 15:48:33 EST
I've done some testing with this today and it appears that 7.1 does not allow
kickstarting through devices other than eth0, although the documentation says
that this should be possible.  
I've tested the same kickstart file with 7.2, and 7.2 does it correctly.  Is it
possible to use 7.2?
Comment 2 James McDermott 2002-01-08 16:14:42 EST
Unfortunatley this is for installation on the production line and 
they are currently installing 7.1 on all these machines. So they need a 
fix for 7.1.
Comment 3 Brent Fox 2002-01-09 12:08:07 EST
What would be considered an acceptable fix?  Do they want an errata or just a
new boot disk?
Comment 4 Brent Fox 2002-01-09 17:23:09 EST
Can you try booting with 'linux ks=floppy ksdevice=eth1' and see if that works?
Comment 5 James McDermott 2002-01-09 17:51:15 EST
They are currently just looking for a fix for production. Errata boot disks
would be great, I already had them try the ksdevice=eth1 and they said they had 
no success. I thought it would be a fine workaround. Still defaulted to eth0
though.
Comment 6 Brent Fox 2002-01-10 14:20:58 EST
Hmm...that seems to work for me.  What kind of ethernet cards do they have?  If
the drivers that eth1 needs aren't on the bootnet.img disk, then I can see how
that would cause a problem.
Comment 7 James McDermott 2002-01-11 14:07:26 EST
The drivers seem to be on the box, but it might be useful 
to note that both cards use the same driver. They retried 
the ksdevice=eth1 and this gave them an address, however 
instead of reading from the kickstart disk it entered interactive 
mode. Did this happen to you to?
Comment 8 James McDermott 2002-01-15 16:43:18 EST
ok we have the ksdevice option working from the start up screen, 
it would be really helpful if we could get it going in the file though.
Comment 9 Jeremy Katz 2002-01-15 16:49:07 EST
They can just modify the syslinux.cfg on the boot disk for 7.1.  And since Brent
says it works even without ksdevice for 7.2, I'm going to go ahead and close this

Note You need to log in before you can comment on or make changes to this bug.