Bug 58106 - NFS mounted home directories hang at login
NFS mounted home directories hang at login
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Depends On:
  Show dependency treegraph
Reported: 2002-01-08 12:54 EST by mike.radomski
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-11 06:56:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mike.radomski 2002-01-08 12:54:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
I have two systems both running RH7.2, kernel 2.4.9-13 and nfs-utils-0.3.1-  I have home directories mounted to from system a to system b.  I am 
able to mount the nfs filesystem on say /mnt and access it.  But when mounting 
it on a user's home, the system hangs at a user login(either ssh,console or 
su - username).  I receive the following messages:

System B: nfs client
nfs: server www2 not responding, still trying
kernel: nfs: task 29 can't get a request slot (over and over with different 

System A (nfs-server)
rpc.mountd: authenticated mount request from xxx.xxx.xxx.xxx:933 for /home

System A /etc/exports is as follows:
/home xxx.xxx.xxx.xxx/,root_squash)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Mount an nfs home directory, and perform some type of login

Actual Results:  System hangs, and cpu load increases to about 8.00

Expected Results:  normal login with a home directory

Additional info:

The systems are clean RH7.2 installs.  The home directory mounting has worked 
in the past with these systems, but since I have run updates, it is failing.
Comment 1 Arjan van de Ven 2002-01-08 12:57:19 EST
any idea which kind of network cards are involved?
Comment 2 mike.radomski 2002-01-08 13:50:23 EST
Yes, they are eepro100's.  The client system is a Compaq DL360 and the server 
is a Compaq ML570.  One other note is the server is using ext3 as a 
Comment 3 mike.radomski 2002-01-09 07:14:56 EST
I have more information on recreating the problem.  I am able to login using a 
stripped down user home. I must have had a script that writes to my home at 
login. The problem actually occurs when I go to write to that home directory 
with a program like ncftp. That is when the session hangs and spikes the 
CPU.   If I touch a file, or vi a small file (and add text) it seems ok.  I 
mounted the server filesystem with and without user/group quotas, it does not 
seem to make a difference.
Comment 4 mike.radomski 2002-01-11 07:05:23 EST
I changed the NIC driver to the e100 driver offered by Compaq for both the 
DL360 and the ML570.  I still experience the same problem.  I found a 
gentleman on Google groups that is having the same problem.  He is what he has 
to say:
Comment 5 Arjan van de Ven 2002-01-11 07:29:02 EST
the e100 driver is generally much worse so I'm not surprised it doesn't fix
things. The link is interested in that 2.4.9-12 would work, while that's
basically the same kernel (with the only change being the XFree86 3D
However 7.1 machines usually don't use ext3 but ext2, maybe that is the issue.
Comment 6 mike.radomski 2002-01-11 07:49:46 EST
I just formatted one of the partition on the nfs server machine ext2 and 
exported it.  Made no difference.  I also tried exporting an ext3 partition to 
a non-smp capable system, a Compaq DeskPro (eepro100); no problems.  I was 
able to do quite a bit of i/o to the nfs mounted fs.
Comment 7 Steve Dickson 2004-08-11 06:56:33 EDT
This seems to be fixed in later kernels.

Note You need to log in before you can comment on or make changes to this bug.