Bug 581090 - inconsistent action naming style
inconsistent action naming style
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-09 21:56 EDT by Jeff Fearn
Modified: 2010-11-23 23:17 EST (History)
4 users (show)

See Also:
Fixed In Version: publican-2.1-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2010-04-09 21:56:01 EDT
Description of problem:
The actions for publican have inconstant naming styles, e.g. clean_ids Vs cleanset

Version-Release number of selected component (if applicable):
1.6.2

How reproducible:
Always

Steps to Reproduce:
1. publican --help
  
Actual results:
Mixed naming style

Expected results:
Consistent naming style

Additional info:
This should only be done in a major version change, like 2.0, since it will affect Users.
Comment 1 Jeff Fearn 2010-05-26 03:10:05 EDT
Three actions and their docs were updated:

cleanset => clean_set
installbrand => install_brand
printtree => print_tree

installbrand will impact existing brands:

1: Update Requires and BuildRequires to 2.0
2: Update %install

Fixed in build 1.99-0.t52

This may be back ported to the 1.6 branch if required.
Comment 2 Fedora Update System 2010-07-06 02:00:16 EDT
publican-2.0-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-2.0-0.fc13
Comment 3 Fedora Update System 2010-07-06 02:00:56 EDT
publican-2.0-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-2.0-0.fc12
Comment 4 Fedora Update System 2010-07-06 13:18:18 EDT
publican-2.0-0.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-2.0-0.fc12
Comment 5 Fedora Update System 2010-07-06 13:19:44 EDT
publican-2.0-0.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-2.0-0.fc13
Comment 6 Fedora Update System 2010-07-06 23:12:58 EDT
publican-2.1-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-2.1-0.fc13
Comment 7 Fedora Update System 2010-07-06 23:13:33 EDT
publican-2.1-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-2.1-0.fc12
Comment 8 Fedora Update System 2010-07-07 13:35:05 EDT
publican-2.1-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-07-07 13:39:40 EDT
publican-2.1-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.