Bug 58110 - neat does not work properply for dialup connections initialized by nonroot users
neat does not work properply for dialup connections initialized by nonroot users
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-08 17:34 EST by Thomas Ploss
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 11:13:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Ploss 2002-01-08 17:34:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Configurations for modem/isdn dialups are not working properply for non root
users, even when that is being set. 

Part reason is, that perms in /etc/sysconfig/networking/devices are not correct,
by default, just root can read the files. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start rp3 to activate a ppp-connection
2.you normally just see ppp0/ppp1 instead of the connection name set
3.change perms in /etc/sysconfig/networking/devices on the ifcfg-files  to 644 
4. restart rp3, names now shown, but dialing may still not work
	

Actual Results:  1) wrong device name shown
2) connection not established, in my case modem dials, but ppp-scripts for
routing dont seem to run (properply another perm prob somewhere)

Expected Results:  to be able to dialup network as a normal user without having
to login as root or do "su"

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-01-08 17:40:18 EST
Can you try the new packages at http://people.redhat.com/teg/neat/ ?
Comment 2 Ngo Than 2002-01-08 17:44:31 EST
You should enable "allow all users to enable and disable the device" in General Tab.

It should work as nonroot
Comment 3 Thomas Ploss 2002-01-09 16:40:32 EST
Hi,

Teg, i have also tested the redhat-config-network-rpm from rawhide, which seems
to be the one you also have at the link mentioned above. but exactly same behavior.

than, i did enable all users to be allowed. If you have that, the system dials,
but you dont get the ip-adress/routes. here are the logfile entries

as root you get the connection (same setup as the non root user tries to dial:
Jan  8 19:20:40 arraigns WvDial: ATM0
Jan  8 19:20:40 arraigns WvDial: OK
Jan  8 19:20:40 arraigns WvDial: Modem initialized.
Jan  8 19:20:40 arraigns WvDial: Sending: ATDT 08450885336
Jan  8 19:20:40 arraigns WvDial: Waiting for carrier.
Jan  8 19:20:40 arraigns WvDial: ATDT 08450885336
Jan  8 19:21:17 arraigns WvDial: CONNECT 115200
Jan  8 19:21:17 arraigns WvDial: Carrier detected.  Starting PPP immediately.
Jan  8 19:21:17 arraigns pppd[1764]: Serial connection established.
Jan  8 19:21:17 arraigns pppd[1764]: Using interface ppp0
Jan  8 19:21:17 arraigns pppd[1764]: Connect: ppp0 <--> /dev/modem
Jan  8 19:21:19 arraigns pppd[1764]: Remote message: /Protocol: Enabled IPCP
address negotiation for
Jan  8 19:21:19 arraigns kernel: PPP BSD Compression module registered
Jan  8 19:21:19 arraigns kernel: PPP Deflate Compression module registered
Jan  8 19:21:19 arraigns pppd[1764]: local  IP address 62.188.15.101
Jan  8 19:21:19 arraigns pppd[1764]: remote IP address 62.188.74.3

now, as non root it looks like the following: ( i just have the log file for
another provider, but promised, root works for it also...

an  8 20:32:42 arraigns WvDial: OK
Jan  8 20:32:42 arraigns WvDial: Modem initialized.
Jan  8 20:32:42 arraigns WvDial: Sending: ATDT 08089933001
Jan  8 20:32:42 arraigns WvDial: Waiting for carrier.
Jan  8 20:32:42 arraigns WvDial: ATDT 08089933001
Jan  8 20:33:21 arraigns WvDial: CONNECT 115200
Jan  8 20:33:21 arraigns WvDial: Carrier detected.  Starting PPP immediately.
Jan  8 20:33:21 arraigns pppd[2714]: Serial connection established.
Jan  8 20:33:21 arraigns pppd[2714]: Using interface ppp0
Jan  8 20:33:21 arraigns pppd[2714]: Connect: ppp0 <--> /dev/modem
Jan  8 20:33:37 arraigns pppd[2714]: Hangup (SIGHUP)
Jan  8 20:33:37 arraigns pppd[2714]: Modem hangup
Jan  8 20:33:37 arraigns pppd[2714]: Connection terminated.
Jan  8 20:33:38 arraigns pppd[2714]: Exit.


best regards
 Thomas
Comment 4 Trond Eivind Glomsrxd 2002-01-09 16:52:08 EST
(MODIFIED is "fixed, waiting for verification by QA". Assigning.)
Comment 5 Thomas Ploss 2002-01-09 17:05:56 EST
Teg,
i dont understand your last update.... the 
[thomas@arraigns thomas]$ rpm -q redhat-config-network
redhat-config-network-0.9.10-1

rpm also doesnt work!

thomas
Comment 6 Trond Eivind Glomsrxd 2002-01-09 17:18:02 EST
The bug was set to "MODIFIED", which is what I explained above. This not being
correct, I set it to assigned.
Comment 7 Thomas Ploss 2002-01-12 17:44:43 EST
additional fault: whenever you modify any setting for a device, the setting for
PEERDNS will be set to yes, if you modify it or not. Thats awful.

Comment 8 Lamar Owen 2002-02-10 00:39:47 EST
It also sets ONBOOT=yes, on my box, for ppp0 even though the checkbox is not
checked.

neat isn't.  Yet, at least.

I can reproduce the behavior here using neat to do virtually anything, even if I
don't touch the ppp devices (I have four ppp setups), the ppp config is changed.
 neat should not change devices that weren't changed during the session. (In my
case I enabled DHCP on eth0 and all my ppp connection's names, set up with
rp3-config, went away, as did the button to control the connection.  HOWEVER,
executing '/sbin/ifup ppp0' as non-root user WORKS.  Just no rp3 buttons.)

System: Toshiba Satellite laptop with Lucent winmodem (linux ltmodem driver
6.00.), Intel eepro100 LAN built-in.

I'll try the updated neat soon enough, but I'm going digging into rp3's
tomfoolery first.
Comment 9 Lamar Owen 2002-02-10 00:47:53 EST
UPDATE:
chmod 644 /etc/sysconfig/network/devices/* /etc/sysconfig/network/profiles/* 

fixed it for me.  I now can control my ppp interfaces by name again, and the
connections work (using it now).

/etc/sysconfig/network/profiles may have had nothing to do with it,though, as it
seems the files in default under it are dynamically generated.
Comment 10 Harald Hoyer 2002-02-20 09:43:02 EST
ONBOOT and PEERDNS fixed in CVS
Comment 11 Ngo Than 2002-03-12 08:04:17 EST
 It's fixed in 0.9.13-1.

Note You need to log in before you can comment on or make changes to this bug.