Bug 581151 - yum update of libftdi attempts to add already existing group
Summary: yum update of libftdi attempts to add already existing group
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libftdi
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lucian Langa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-10 14:58 UTC by Quentin Armitage
Modified: 2010-05-24 19:33 UTC (History)
2 users (show)

Fixed In Version: libftdi-0.17-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-22 01:46:28 UTC


Attachments (Terms of Use)

Description Quentin Armitage 2010-04-10 14:58:00 UTC
Description of problem:
yum update reports error:
groupadd: group 'plugdev' already exists

Version-Release number of selected component (if applicable):
libftdi-0.17-2.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1. yum update libftdi
2.
3.
  
Actual results:
Attempts to add already existing group plugdev

Expected results:
Only adds group if it does not exist

Additional info:
The %pre script as the line:
getent group GROUPNAME >/dev/null || groupadd -r plugdev 

Presumably GROUPNAME should say plugdev

Comment 1 Michal Jaegermann 2010-04-10 17:43:36 UTC
(In reply to comment #0)

> The %pre script as the line:
> getent group GROUPNAME >/dev/null || groupadd -r plugdev 
> 
> Presumably GROUPNAME should say plugdev    

Luckily this is not the whole %pre script.  The next line reads 'exit 0' or an update would be abandoned due to a script failure.

It would be simpler just to follow a common pattern of such scripts and use:

groupadd -r plugdev >/dev/null 2>&1 || :

Comment 2 Fedora Update System 2010-05-05 05:47:38 UTC
libftdi-0.17-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libftdi-0.17-4.fc13

Comment 3 Fedora Update System 2010-05-05 05:48:30 UTC
libftdi-0.17-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libftdi-0.17-3.fc12

Comment 4 Fedora Update System 2010-05-05 07:21:18 UTC
libftdi-0.17-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libftdi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libftdi-0.17-4.fc13

Comment 5 Fedora Update System 2010-05-06 03:43:48 UTC
libftdi-0.17-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libftdi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libftdi-0.17-3.fc12

Comment 6 Fedora Update System 2010-05-22 01:46:24 UTC
libftdi-0.17-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-05-24 19:33:30 UTC
libftdi-0.17-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.