Bug 5812 - Netscape still hangs on some java pages. Here's a trace.
Netscape still hangs on some java pages. Here's a trace.
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 7971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-10 17:25 EDT by George Karabin
Modified: 2014-03-16 22:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-02 13:27:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Karabin 1999-10-10 17:25:38 EDT
As much as netscape has improved on Linux, it still doesn't
get along with serious Java programs very well.

As usaual, I'm working on a Sunday, and want to pay
attention to my sports games. The NFL has this fantastic
applet (http://espn.go.com/nfl/week/sco.html , NFL.com
GameDay Live, linked to by
javascript:launchGameDayWindow('buf').)

Netscape runs this applet fine for a while, and then hangs.
I've usually got a couple of windows open, and the Mail
application as well. The GDB traces always show the same
thing.

I'm running on RH6.1, on a K6-2 300, with 64Megs of RAM,
altough I've seen the problem on my PIII-450, 246Megs at
work as well.

Here are the RPMs:
netscape-communicator-4.7-1.1
netscape-common-4.7-1.1

Here's the trace. It's always hanging in the same place, at
least after a couple of traces. Since I don't have source
handy, I haven't looked into it any more than this. It's
interesting that it's hanging in X, however. Might be a bug
in there worth hunting down.

junkie% gdb /usr/lib/netscape/netscape-communicator
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public
License, and you are
welcome to change it and/or distribute copies of it under
certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show
warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) run
Starting program: /usr/lib/netscape/netscape-communicator

Program received signal SIGINT, Interrupt.
0x400e5c9a in _XFlushInt () from /usr/X11R6/lib/libX11.so.6
(gdb) ba
#0  0x400e5c9a in _XFlushInt () from
/usr/X11R6/lib/libX11.so.6
#1  0x400e5c5b in _XFlush () from /usr/X11R6/lib/libX11.so.6
#2  0x400dd319 in PutImageRequest () from
/usr/X11R6/lib/libX11.so.6
#3  0x400dd49e in PutSubImage () from
/usr/X11R6/lib/libX11.so.6
#4  0x400dd850 in XPutImage () from
/usr/X11R6/lib/libX11.so.6
#5  0x874cb75 in image_Done ()
#6  0x8749589 in Dir32IcmTrnUnsImageConvert ()
#7  0x874cfc3 in
sun_awt_image_ImageRepresentation_setBytePixels ()
#8  0x87503ae in
Java_sun_awt_image_ImageRepresentation_setBytePixels_stub ()
#9  0x870144a in invokeNativeMethod ()
#10 0x8704a80 in ExecuteJava ()
#11 0x8706617 in do_execute_java_method_vararg ()
#12 0x870625a in do_execute_java_method ()
#13 0x8724fb8 in sun_awt_image_GifImageDecoder_parseImage ()
#14 0x8714219 in
Java_sun_awt_image_GifImageDecoder_parseImage_stub ()
#15 0x870144a in invokeNativeMethod ()
#16 0x8704a80 in ExecuteJava ()
#17 0x8706617 in do_execute_java_method_vararg ()
#18 0x8706028 in execute_java_dynamic_method ()
#19 0x87157ef in java_lang_System_setSystemIO ()
#20 0x873e468 in start_thread ()
#21 0x893ad1c in HopToad ()
#22 0x893ad5b in HopToadNoArgs ()
#23 0x893adc4 in PR_Start ()
Comment 1 Bill Nottingham 1999-10-18 15:33:59 EDT
Hmm... I haven't noticed this with the same applet. That's
in the X threading code though. Presumbably a deadlock somewhere
in Netscape.
Comment 2 George Karabin 1999-10-20 12:30:59 EDT
I don't see it right now, either! I would guess that the only time
that it really makes sense to run the applet is on a morning during
all of the NFL games.

The applet gets no updates of game statistics unless games are in
progress. Maybe the rapid updates during a game triggers the bug?

If you've got time (I realize this may not be an easy one to fix even
if you can duplicate it), and a spare machine, maybe the bug can be
duplicated by selecting the game update for a game scheduled for this
weekend. I'd think you could set that up before the weekend, and check
on it the following week.

Thanks...
Comment 3 Bill Nottingham 1999-10-20 12:39:59 EDT
No, I'm saying I've run the applet during games, and not noticed
the hang. I'll try again, but I don't know if I'll be able to
reproduce it.
Comment 4 George Karabin 1999-10-21 01:32:59 EDT
Then I guess I've got a problem. For what it's worth, I'm running on a
K6-2 266, Intel 430TX chipset, 66MHz bus, 64M of RAM and a 16MB
Diamond Viper V550 PCI video card. I'll try running again this weekend
and see if I can duplicate it.
Comment 5 hchcheng 1999-10-22 22:10:59 EDT
I am glad to see someone with the same problem I am having, since
everyone else I talked to just told me to fix my font path!  I am also
running 4.7-1.1, but I am actually running RH 6.0 (because the
installer wouldn't work for me).  The trace is exactly the same, but I
would like to add that I have experienced problems with just about
every Java site that I visit, but it doesn't always happen.  This one
seems to give me crashes more frequently:

  http://station.nasa.gov/

There is a little scroller on the right, if it works.

A "workaround" for me is to just disable Java support, but that's not
much of a solution.

I have also observed that it happens more frequently when I click on a
link to a Java page, and while waiting, move the mouse to another
window so that the Netscape window loses focus (but I have never
collected statistics).  This may or may not have anything to do with
the problem.
Comment 6 George Karabin 1999-10-22 23:56:59 EDT
I tried out your link to http://station.nasa.gov/, and got a lockup
after leaving it running for a while. I've noticed that netscape tends
to crash hard when the fontpath is bad, on a variety of java pages. I
think I have my fontpath correctly doctored (attached below).

The only other thing that I can think of that may not be stock on my X
setup is that I changed /etc/X11/fs/config to default to 100dpi a long
time ago, when the default was 75. Here's the line I'm using (I have
no idea what the default is today - I guess I should check into that).

# 100 x 100 and 75 x 75
default-resolutions = 100,100,75,75

Here's my font path:

/usr/sbin/chkfontpath
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/100dpi
8: /usr/share/fonts/default/Type1
9: /usr/X11R6/lib/X11/fonts/75dpi
Comment 7 George Karabin 1999-10-24 14:03:59 EDT
I tried the NFL link again this weekend and got the same problem. It
took a while for the problem to occur, after I browsed through a
couple of games, and then did some browsing elsewhere while the NFL
window ran in the background. YMMV.
Comment 8 Bill Nottingham 1999-11-01 12:18:59 EST
I actually was able to reproduce this this weekend.
I'll forward it on to netscape; not sure if there's anything
we can do about it, though. :(
Comment 9 George Karabin 1999-11-02 00:57:59 EST
Thanks. My guess is the solution is to wait for Mozilla to enter beta
:)
Comment 10 SI Reasoning 1999-12-11 03:31:59 EST
Ever since I upgraded to Redhat's new gnome files, the Netscape crashes have
become worse. It used to be limited to a handful of sites, now it happens all of
the time and is getting very irritating. I can find no pattern to it either,
sometimes it will lock up even though I just have it up and am working with
something else.
Comment 11 Bill Nottingham 2000-02-01 22:03:59 EST
*** Bug 7971 has been marked as a duplicate of this bug. ***
Comment 12 hchcheng 2000-06-07 10:30:26 EDT
Is there any chance that this can be fixed any time soon?

Note You need to log in before you can comment on or make changes to this bug.