This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 58122 - missing md / xfs module handling; tmpfs workaround
missing md / xfs module handling; tmpfs workaround
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-09 02:18 EST by Andreas Piesk
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-09 02:24:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
workaround for tmpfs issue (973 bytes, patch)
2002-01-09 02:23 EST, Andreas Piesk
no flags Details | Diff
patch for md + xfs issue (747 bytes, patch)
2002-01-09 02:23 EST, Andreas Piesk
no flags Details | Diff

  None (edit)
Description Andreas Piesk 2002-01-09 02:18:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
1. md module is missing if raid modules are selected
2. xfs modules aren't handled
3. mkinitrd (creating loop device) will failed on tmpfs volume

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. build a ramdisk with raid modules. md module will not be included.
2. build a ramdisk for a system with xfs as root-fs. xfs modules will not be 
included.
3. build a ramdisk on a system with tmpfs as fs for $TMP. mkinitrd failes 
because of no available loopdevices.

Additional info:
Comment 1 Andreas Piesk 2002-01-09 02:23:15 EST
Created attachment 42071 [details]
workaround for tmpfs issue
Comment 2 Andreas Piesk 2002-01-09 02:23:56 EST
Created attachment 42072 [details]
patch for md + xfs issue
Comment 3 Erik Troan 2002-01-16 15:31:00 EST
Fixed in 3.3.1

Note You need to log in before you can comment on or make changes to this bug.