Bug 58124 - xsltproc ignores -v after '-o output'
xsltproc ignores -v after '-o output'
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libxml2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-09 05:20 EST by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-20 08:36:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-01-09 05:20:49 EST
Description of Problem:
Unless -v is the first parameter it seems to be ignored.

Version-Release number of selected component (if applicable):
libxml2-2.4.12-0.7

How Reproducible:
100%

Steps to Reproduce:
1. xsltproc -o /dev/null -v stylesheet.xsl file.xml

Actual Results:
Output is not verbose.

Expected Results:
Output is verbose.
Comment 1 Daniel Veillard 2002-01-20 08:36:06 EST
Fixed in Gnome CVS, the problem was simply an off-by-one error
when the -o option was used, leading the next option to be ignored.
BTW the --noout is somewhat equivalent to -o /dev/null and seems
a better option to use in scripts

http://cvs.gnome.org/bonsai/cvsquery.cgi?module=libxslt&branch=HEAD&branchtype=match&dir=libxslt&file=&filetype=match&who=veillard&whotype=match&sortby=Date&hours=&date=explicit&mindate=01%2F20%2F02+08%3A33&maxdate=01%2F20%2F02+08%3A35&cvsroot=%2Fcvs%2Fgnome

The fix will be included in next version of libxslt (1.0.11 ?),

  thanks for the report,

Daniel

Note You need to log in before you can comment on or make changes to this bug.