Bug 58128 - Sources won't compile with Intel C/C++ compiler (icc)
Sources won't compile with Intel C/C++ compiler (icc)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-09 07:29 EST by Sysoltsev Slawa
Modified: 2007-03-26 23:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 11:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for redeclaration of variable with various keywords (295 bytes, patch)
2002-01-09 07:30 EST, Sysoltsev Slawa
no flags Details | Diff

  None (edit)
Description Sysoltsev Slawa 2002-01-09 07:29:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
If we using Intel C/C++ compiler (icc), we got an error while building 
package 'ypserv-1.3.12' on ypxfrd.c:
ypxfrd.c
"ypxfrd.c", line 81: error: declaration is incompatible with "volatile int 
children" (declared at line 22 of "ypserv.h")
  int children = 0;
      ^
looking into sources we see that variable 'children' was previously declared 
as 'volatile int' in "ypserv.h" and redeclared just as 'int' in "ypxfrd.c". It 
is OK for gcc (gcc just ignores first 'volatile' this way), but normally C 
compiler should emit error or at least warning.
I try to change second declaration from 'int' to 'volatile int' 
(file "ypxfrd.c", line 81) and package was built.

With this I create and attach patch for eliminate this error in order to 
increase Red Hat Linux portability.

Version-Release number of selected component (if applicable):
1.3.12

How reproducible:
Always

Steps to Reproduce:
You are unable to reproduce the error now even if you have Intel C/C++ 
compiler, because Intel C/C++ compiler doesn't support __attribute__ ((unused)) 
on function parameters yet.

Actual Results:  Compile-time error.

Expected Results:  Succesfully built package.

Additional info:
Comment 1 Sysoltsev Slawa 2002-01-09 07:30:46 EST
Created attachment 42092 [details]
Patch for redeclaration of variable with various keywords
Comment 2 Alexander Larsson 2002-08-15 05:03:36 EDT
We don't support icc, please send the patch upstream instead. Upstream here is
kukuk@suse.de

Note You need to log in before you can comment on or make changes to this bug.