This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 581376 - virt-manager can't detect 32-bit qemu-kvm memory limit
virt-manager can't detect 32-bit qemu-kvm memory limit
Status: CLOSED DUPLICATE of bug 570902
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
i386 Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-11 23:17 EDT by Lijian Xu
Modified: 2010-04-13 12:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 12:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lijian Xu 2010-04-11 23:17:41 EDT
Description of problem:
    It seems that qemu-kvm supports only 2G memory for guest on 32-bit systems, if I give it more than 2047MB, virt-manager doesn't report an error immediately, but a traceback after create the guest or when starting it.

Version-Release number of selected component (if applicable):
    * kernel-2.6.33.1-19.fc13
    * libvirt-0.7.7-1.fc13
    * python-virtinst-0.500.2-3.fc13
    * qemu-0.12.3-6.fc13
    * seabios-0.5.1-1.fc13
    * virt-manager-0.8.3-2.fc13 

How reproducible:
    Always.

Steps to Reproduce:
1. Setup a i686 host system.
2. Create a Virtual Machine with more than 2047M memory(eg. 2048M).
3. Go next and start the machine.
  
Actual results:
    A traceback with message:

    Unable to complete install '<class 'libvirt.libvirtError'> internal error Process exited while reading console log output: qemu: at most 2047 MB RAM can be simulated

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1510, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 798, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 899, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 1147, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Process exited while reading console log output: qemu: at most 2047 MB RAM can be simulated

Expected results:
    Friendly message when memory >= 2048, or upper limit for the memory-input textbox.

Additional info:
    None.
Comment 1 Cole Robinson 2010-04-13 12:50:38 EDT

*** This bug has been marked as a duplicate of bug 570902 ***

Note You need to log in before you can comment on or make changes to this bug.