Bug 58147 - aspell-0.33.7.1-2 is very confused?
aspell-0.33.7.1-2 is very confused?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: aspell (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-09 17:43 EST by Jonathan Kamens
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 14:42:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-09 17:44:00 EST
Run "ispell -a -m -B" with aspell-0.33.7.1-2 and pspell-0.12.2-4 and feed it the
following input:

<blank line>
!
+
^\hyphenation{Clear
^DDTS}

After the last line (the one containing DDTS), you'll see:

& sgml 42 22: SGML, Simla, sigma, GM, Sm, gm, ml, XML, signal, Gal, Gil, SAM,
Sal, Sam, Sim, Sol, gal, gel, sol, sum, GMT, MGM, Sgt, smile, Saul, sail, same,
seal, sell, semi, sill, soil, soma, some, soul, sumo, SIMD, STOL, Sims, sump,
sums, HTML
& tex 16 27: TeX, Tex, TWX, text, Rex, TX, Dex, tax, tux, Te, ex, Mex, hex, lex,
sex, vex

I have no idea why.  Emacs doesn't either.  It reports, "Ispell misalignment:
word `sgml' point 26; probably incompatible versions".

Downgrading to aspell-0.33.7-1 appears to make the problem go away.

Well, OK, I think I have a guess -- something is getting confused when emacs
tells ispell to enter tex mode by sending it a "+".
Comment 1 Jonathan Kamens 2002-01-09 18:11:37 EST
I was wrong.  Downgrading aspell didn't help.  Neither did downgrading pspell. 
Emacs is still confused, but it's feeding slightly different input to aspell:

!
+
^\thispagestyle{plain}
^\hyphenation{Clear

I think part of the problem is probably that Emacs is not filtering out these
tex commands, but other than that, I think aspell's reaction is probably still
wrong.
Comment 2 Trond Eivind Glomsrxd 2002-01-17 15:20:13 EST
Can you try the rpms at http://people.redhat.com/teg/aspell/ ?
Comment 3 Jonathan Kamens 2002-01-19 20:02:15 EST
1) What have you changed (i.e., why should I expect these RPMs to work :-)?

2) What pspell package should I use them with?
Comment 4 Trond Eivind Glomsrxd 2002-01-21 14:27:06 EST
You shouldn't need to change the pspell package (use the standard RHL 7.2 one),
as for what's done, it's magic (also known as actually use the correct version
of the tarball).
Comment 5 Jonathan Kamens 2002-01-21 14:42:25 EST
Well, I'm now using aspell-0.33.7.1-6 and pspell-0.12.2-7, and everything
appears to work.

Incidentally, I'm not convinced you're right that the 7.2 version of pspell
would work; I think there are link-time incompatibilities.  You may want to
check that, and if so, out a prereq line in the aspell package.
Comment 6 Trond Eivind Glomsrxd 2002-03-20 10:49:35 EST
Should have closed this on the above comment :)

Note You need to log in before you can comment on or make changes to this bug.