Bug 581535 - >=2.6.33.1-26 causes ACPI panic in acpi_ex_read_data_from_field
>=2.6.33.1-26 causes ACPI panic in acpi_ex_read_data_from_field
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 581882 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-12 10:51 EDT by Robert de Rooy
Modified: 2010-06-01 21:42 EDT (History)
11 users (show)

See Also:
Fixed In Version: kernel-2.6.33.2-57.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-16 15:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of display with panic shown (3.03 MB, image/jpeg)
2010-04-12 10:51 EDT, Robert de Rooy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 15746 None None None Never
Launchpad 561151 None None None Never

  None (edit)
Description Robert de Rooy 2010-04-12 10:51:11 EDT
Created attachment 405983 [details]
Picture of display with panic shown

Description of problem:
ThinkPad T41 running F13 Alpha with updates

Starting with the 2.6.33.1-26 kernel the system immediately panics on boot in the ACPI code.
the system boots normally with older kernels or by booting with acpi=off

Version-Release number of selected component (if applicable):
>= kernel-2.6.33.1-26 panics on boot (tested up to kernel-2.6.33.2-38.fc13)
<= kernel-2.6.33.1-24 works fine

How reproducible:
Each boot

Steps to Reproduce:
1. ThinkPad T41
2. Install kernel-2.6.33.1-26 or newer
3.
  
Actual results:
Panic on boot

Expected results:
Normal boot

Additional info:
Panic is not logged
Comment 1 Robert de Rooy 2010-04-12 10:55:46 EDT
Kernel changelog shows this as the likely suspect as having changed between -24 and -26

* Tue Mar 30 2010 Chuck Ebbert <cebbert@redhat.com>
 - ACPI EC fixes pending upstream: 
    acpi-ec-add-delay-before-write.patch
    acpi-ec-allow-multibyte-access-to-ec.patch
Comment 2 Robert de Rooy 2010-04-12 11:08:56 EDT
Ubuntu is having the same problem
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561151
Comment 3 Chuck Ebbert 2010-04-13 11:36:48 EDT
*** Bug 581882 has been marked as a duplicate of this bug. ***
Comment 4 Chuck Ebbert 2010-04-13 13:17:58 EDT
Should be fixed in kernel-2.6.33.2-44.fc13
Comment 5 James Laska 2010-04-14 07:41:19 EDT
Attaching the full panic I'm seeing for future searching.

BUG: unable to handle kernel NULL pointer dereference at 00000009
IP: [<c060f5bc>] acpi_ex_read_data_from_field+0x175/0x1a1
*pde = 00000000 
Oops: 0000 [#1] SMP                                                          
last sysfs file:                                                             
Modules linked in:                                                           
                                                                             
Pid: 36, comm: async/0 Not tainted 2.6.33.2-41.fc13.i686 #1 2687DUU/2687DUU                                         
EIP: 0060:[<c060f5bc>] EFLAGS: 00010246 CPU: 0                                                                      
EIP is at acpi_ex_read_data_from_field+0x175/0x1a1                                                                  
EAX: 00000000 EBX: 00000000 ECX: 00000000 EDX: 00000010                                                             
ESI: 00000000 EDI: 00000000 EBP: c1a57d5c ESP: c1a57d48                                                             
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068                                
Process async/0 (pid: 36, ti=c1a56000 task=c1a695a0 task.ti=c1a56000)        
Stack:                                                      
 00000010 c1a57d6c c1a59534 f6c4e3c8 f6c43cc0 c1a57d7c c0615667 00000011
<0> c1a593b0 00000000 f6c43cc0 c1a59534 c1a593b0 c1a57d98 c06100b4 00000004
<0> c1a70818 c1a593b0 f6d62370 f6d62370 c1a57db0 c0609eec 11a57db4 00000040
Call Trace:                                                 
 [<c0615667>] ? acpi_ex_resolve_node_to_value+0x1b7/0x22c   
 [<c06100b4>] ? acpi_ex_resolve_to_value+0x21b/0x253
 [<c0609eec>] ? acpi_ds_evaluate_name_path+0x71/0xdc
 [<c0608890>] ? acpi_ds_exec_end_op+0x83/0x483
 [<c061cfe5>] ? acpi_ps_parse_loop+0x784/0x8eb
 [<c061c1c1>] ? acpi_ps_parse_aml+0xd4/0x304
 [<c061d7fe>] ? acpi_ps_execute_method+0x1bd/0x29f
 [<c0618460>] ? acpi_ns_evaluate+0x140/0x246
 [<c0617e11>] ? acpi_evaluate_object+0x121/0x248
 [<c062aca4>] ? acpi_battery_update+0xb3/0x1f3
 [<c062b6cc>] ? acpi_battery_add+0xb4/0x164
 [<c05ffa73>] ? acpi_device_probe+0x3f/0x147
 [<c06635b7>] ? driver_probe_device+0xca/0x1d2
 [<c0663707>] ? __driver_attach+0x48/0x64
 [<c0662b9e>] ? bus_for_each_dev+0x42/0x6c
 [<c06633a5>] ? driver_attach+0x19/0x1b
 [<c06636bf>] ? __driver_attach+0x0/0x64
 [<c0662e2d>] ? bus_add_driver+0x101/0x24a
 [<c0663972>] ? driver_register+0x81/0xe8
 [<c0600ecc>] ? acpi_bus_register_driver+0x3f/0x43
 [<c0a5cecb>] ? acpi_battery_init_async+0x24/0x34
 [<c0458676>] ? async_thread+0xf5/0x1d9
 [<c043720e>] ? default_wake_function+0x0/0x12
 [<c0458581>] ? async_thread+0x0/0x1d9
 [<c045214c>] ? kthread+0x6f/0x74
 [<c04520dd>] ? kthread+0x0/0x74
 [<c0403982>] ? kernel_thread_helper+0x6/0x10
Code: 7e c0 68 b6 00 00 00 68 00 10 00 00 e8 cc 11 01 00 0f b6 43 09 83 c4 24 e8 93 4e 00 00 8b 4d ec 89 fa 89 d8 e8 ce 19 00 00 89 c7 <0f> b6 43 09 e8 48 4e 00 00 85 ff 74 09 89 f0 e8 95 32 01 00 eb 
EIP: [<c060f5bc>] acpi_ex_read_data_from_field+0x175/0x1a1 SS:ESP 0068:c1a57d48
CR2: 0000000000000009
---[ end trace 0f9bd9f9cd53f811 ]---
async/0 used greatest stack depth: 5952 bytes left
Non-volatile memory driver v1.3
Linux agpgart interface v0.103
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
Comment 6 Robert de Rooy 2010-04-14 11:42:46 EDT
I can confirm that the issue is resolved with 2.6.33.2-46.fc13.i686
Comment 7 Steven Moix 2010-04-14 11:55:31 EDT
It's also fixed for me with kernel-PAE-2.6.33.2-46.fc13.i686 on a ThinkPad x301.
Comment 8 Hicham HAOUARI 2010-04-14 13:16:56 EDT
Fixes it for me too in here.
Comment 9 James Laska 2010-04-16 15:38:17 EDT
Closing this as it's fixed for me, and several previous reporters and available in Fedora 13.
Comment 10 Fedora Update System 2010-04-20 10:05:49 EDT
kernel-2.6.33.2-57.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.33.2-57.fc13
Comment 11 Fedora Update System 2010-04-25 09:55:16 EDT
kernel-2.6.33.2-57.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Olimer Pinzón 2010-06-01 21:42:23 EDT
I'm using Fedora 13 with kernel 2.6.33.5-112 on an Asus F81s Notebook and it's having the same problem, it can not boot with acpi enabled.

Note You need to log in before you can comment on or make changes to this bug.