Bug 58159 - First time login to X for non root failed after (re)boot
First time login to X for non root failed after (re)boot
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 07:39 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 08:06:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-10 07:39:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010726
Netscape6/6.1

Description of problem:
If non-root user shutdown laptop from X, next time laptop boots first user login
fails, second always works. No problem for root. Problem exists on my laptop,
but it always ok on my desktop (both RH7.1). It looks like something didn't
clean up during shutdown...
shutdown is done from GNOME session.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.add new user 
2.add right to shutdown
3.login as user
4.shutdown laptop from GNOME
5.after boot to level 5, login to GNOME session as user

	

Actual Results:  first time login after reboot fails

Expected Results:  loigin without problems

Additional info:

All software installed from CD made from ISO images on your web site.

It looks like some cleanup related to X11 for this user isn't done, when laptop
is shutdown by user from GNOME
Comment 1 Ngo Than 2002-01-10 07:47:20 EST
gdm is the right component.
Comment 2 Need Real Name 2002-01-10 08:06:06 EST
No one in the linux related news group is able to help, but situation is really
annoying: to login twice all the time...
Comment 3 Havoc Pennington 2002-02-11 18:27:48 EST
I can't reproduce, and gdm has an enormous number of bugfixes since 7.1. 
Assuming fixed in 7.2/rawhide.

Note You need to log in before you can comment on or make changes to this bug.