Bug 58168 - Broadcom 5701 causing kernel panic w/ nttcp traffic
Broadcom 5701 causing kernel panic w/ nttcp traffic
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 09:09 EST by Clay Cooper
Modified: 2013-07-02 22:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-25 13:02:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clay Cooper 2002-01-10 09:09:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
Bordeaux w/ 64GB ram, A02 Bios, broadcom nic slot 8, w/ 7.2 Itanium Gold
installed.  

Starting 3 instances of nttcp on a gigabit line with the following parameters:

./nttcp -T -n128  -l262144 -w256 $1
./nttcp -T -n128  -l262144 -w256 -r $1 -t
And then...
Kernel panic:  Aiee, killing interrupt handler!
In interrupt handler -- not syncing

This has been reproduced twice so far.  Once within an hour.  The second time
occurred overnight.  I have previously tested this driver several times without
issue in previous release candidates.

It is probable that, although using multiple instances of nttcp to verify the
bandwidth, I did my sustained testing with only one instance. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Itanium Gold on a bordeaux with a broadcom 5701 nic
2.  Begin multiple nttcp instances on a gigabit line
3.  Look for kernel panic in interrupt handler
	

Additional info:
Comment 1 Matt Domsch 2002-01-10 11:49:05 EST
That driver is v2.0.28.  Broadcom has made available to Dell v2.0.34 which the 
SNaC team is testing.  Clay, can you get that from Thomas and try?
-Matt
Comment 2 Clay Cooper 2002-01-11 08:43:31 EST
Reproduced kernel panic twice w/ bcm5700 v2.0.34

Comment 3 Matt Domsch 2002-01-11 16:12:47 EST
Until this driver is cleaned up then (either by Broadcom or RH), Dell won't 
offer the Broadcom cards on the PowerEdge 7150.
Comment 4 Michael K. Johnson 2002-08-06 11:26:19 EDT
Matt, do you know if Broadcom's more recent versions of their driver
fix this problem?
Comment 5 Jeff Garzik 2002-10-25 13:02:08 EDT
Can you please test nttcp and the latest "tg3" driver, to see if this problem
has been resolved?

Actually, my preference would be to close this bug and open a new one if tg3 has
a problem, since bcm570x driver is so grotty.  But I will leave this bug open
for a while, until I get a response to this comment at least.
Comment 6 Jeff Garzik 2002-12-09 14:32:30 EST
No response on this bug in a long time, so I'm going to close it.

Please re-open if tg3 driver version 1.2 does not solve this problem.

Note You need to log in before you can comment on or make changes to this bug.