Bug 581698 - add job support for storage driver, allow cancelling volume creation
Summary: add job support for storage driver, allow cancelling volume creation
Keywords:
Status: CLOSED DUPLICATE of bug 524205
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
: 830676 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-13 02:37 UTC by Zachary Amsden
Modified: 2016-03-20 23:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-20 23:41:03 UTC


Attachments (Terms of Use)

Description Zachary Amsden 2010-04-13 02:37:25 UTC
Description of problem:

Constant spinning busy cursor never finishes after aborted attempt to add a drive.

Version-Release number of selected component (if applicable):

RHEL 5.5-rc1

etherboot-roms-kvm-5.4.4-13.el5
etherboot-zroms-kvm-5.4.4-13.el5
kvm-qemu-img-83-164.el5
kmod-kvm-83-164.el5
kvm-tools-83-164.el5
kvm-83-164.el5
python-virtinst-0.400.3-9.el5
virt-manager-0.6.1-12.el5
libvirt-0.6.3-33.el5
libvirt-cim-0.5.8-3.el5
libvirt-python-0.6.3-33.el5
virt-viewer-0.0.2-3.el5



How reproducible: seems 100%


Steps to Reproduce:
1.  Create a new virtual machine
2.  After creating a disk, cancel out of the progress window while space is allocated.
3.  Now attempt to add new disk; new attempt never finishes
  
Actual results:

Disk should stop being created and be removed or new dialogs should not hang.

Expected results:

Dialogs hang, causing new disks not to appear in the machine description.  Old disk wasn't aborted, I had to remove it manually - this was the whole point - I didn't want the disk in /var/libvirt/images and tried to change it.

Additional info:

Comment 1 Zachary Amsden 2010-04-13 02:39:21 UTC
Note: exiting and restarting virt-manager made the problem disappear.  This python message was found on exit:

Unable to complete install: 'Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 655, in add_device
    self.vm.add_device(xml, vmxml)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1175, in add_device
    self.get_connection().define_domain(newxml)
  File "/usr/share/virt-manager/virtManager/connection.py", line 711, in define_domain
    self.vmm.defineXML(xml)
AttributeError: 'NoneType' object has no attribute 'defineXML'
'

Comment 2 Cole Robinson 2010-05-04 16:31:31 UTC
The issue here is that disk allocation isn't cancelable. There is some support in libvirt for running async jobs now, need to investigate if it will even help solve this problem.

Comment 3 Daniel Berrangé 2010-05-04 16:41:36 UTC
THe current APIs only operate against virDomainPtr objects, but the design can trivially be replicated against virStoragePool/VolPtr objects

Comment 4 Cole Robinson 2011-03-10 15:42:41 UTC
Since it's unlikely that the required libvirt support will appear in any RHEL5 release at this point, reassigning to RHEL6

Comment 6 RHEL Product and Program Management 2011-04-04 01:46:47 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Cole Robinson 2011-04-07 16:59:39 UTC
Since this is a libvirt RFC not filed by a customer, reassigning to upstream libvirt.

Comment 8 Ján Tomko 2015-03-17 15:13:20 UTC
*** Bug 830676 has been marked as a duplicate of this bug. ***

Comment 9 Cole Robinson 2016-03-20 23:41:03 UTC

*** This bug has been marked as a duplicate of bug 524205 ***


Note You need to log in before you can comment on or make changes to this bug.