Bug 5817 - Signal 11 when compiling the kernel
Signal 11 when compiling the kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: egcs (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 6617 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-10 23:27 EDT by m.flower
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-02 16:55:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description m.flower 1999-10-10 23:27:30 EDT
I am running on a Cyrix 6x86 P200+ machine. Compiling the
kernel gets a signal 11 from the c compiler.

This problem occured in a previous  redhat release, and
there was a re-release of the compiler. The problem is
actually a H/W problem with the 6x86 from memory.

I would like to know if there is going to be another work
around.

...mcf
Comment 1 Jim Kingdon 1999-10-26 12:22:59 EDT
Can you be more specific about this fix which was issued in the past?
I saw a possible reference to something of the sort in bugzilla
1115 but I searched a number of mailing lists, bugzilla, &c, for
"Cyrix" and I didn't find it.
Comment 2 Jim Kingdon 1999-10-26 12:27:59 EDT
Found it.
http://www.redhat.com/corp/support/errata/rh50-errata-general.html
under "cyrix".

As nearly as I can tell from what is there, they didn't actually
fix anything in that gcc, they just found that it seemed to not
happen to hit the crash.  If you find anything more about what
is going on, feel free to let us know.
Comment 3 Jim Kingdon 1999-11-02 16:07:59 EST
*** Bug 6617 has been marked as a duplicate of this bug. ***

Hardware: Cyrix 6x86 PR200+, 64Mb RAM, 128Mb swap

I have been running RedHat on this box since (at least) 5.2,
very few problems. I previously had upgraded to 6.0 with no
real problems, I upgraded to 6.1 yesterday, no problems
during the upgrade.

I then tried to re-compile php and got serious problems with
egcs. During the make, I got seemingly random compiler
crashes, error was:

gcc: Internal compiler error: program cc1 got fatal signal
11

typing make again sometimes compiled a few more modules,
sometimes not.

I know errors of this type have been attributed to hardware
problems in the past, but I'm fairly sure that is _not_ the
case here. I noticed that the version of egcs is the same in
both RH6.1 and RH6.0, so I re-installed the older egcs
package using:

rpm --force -ivh egcs-1.1.2-12.i386.rpm

I then did a make clean and a make in the php directory and
it built without problem, so it looks like there has been a
change between egcs-1.1.2-12.i386.rpm and
egcs-1.1.2-24.i386.rpm which is causing problems (at least
for me :-).

I did not try to re-install the later version again, I will
do so and let you know if this fixes things (ie in case a
wierd dependency thing happened).

(There was a problem like this a few RedHat releases ago,
RedHat provided a special build of gcc/egcs to fix the
problem.)

I use several 'real' pentiums here at work, currently
running 6.0, I may try upgrading one, though I'm a little
apprehensive as I cannot afford much downtime. I got the 6.1
distribution from ftp.redhat.com as an iso image, md5sum was
ok, wrote it with Adaptec's Easy CD Creator on Win32, no
problems.

Any suggestions?

Thanks,

Simon
Comment 4 Anonymous 1999-11-02 16:36:59 EST
Last night I tried removing (rpm -e) all traces of egcs, then doing a
fresh install of egcs from the 6.1 CD. I used rpm --verify to check
it, no complaints. I tried the php compile, and again it failed on the
first C file. Again I removed egcs and re-installed from 6.0 and the
compile was fine.

Can I find out what was changed between egcs-1.1.2-12 and
egcs-1.1.2-24 ? the last number is a build number isn't it? Why was it
rebuilt? What changed?

Simon
-----
Comment 5 Jim Kingdon 1999-11-02 16:55:59 EST
The first place to look in terms of what has changed is
"rpm -q --changelog egcs".

For more detail, do something like:
  mkdir twelve; cd twelve
  rpm2cpio <egcs-1.1.2-12.src.rpm | cpio --extract
  cd ..; mkdir twentyfour; cd twentyfour
  rpm2cpio <egcs-1.1.2-24.src.rpm | cpio --extract
  cd ..
  diff -u -r twelve twentyfour

My guess is that the difference in -12 and -24 isn't any
of the patches, though, my guess is that it changed the
location of some code/data or something else basically
inexplicable.  If you find out more, please do let us know.

Note You need to log in before you can comment on or make changes to this bug.