Bug 581706 - MLDonkey is outdated and need update
Summary: MLDonkey is outdated and need update
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mldonkey   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 564999
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-13 03:15 UTC by Howard Ning
Modified: 2010-04-20 13:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-20 13:16:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Howard Ning 2010-04-13 03:15:29 UTC
Description of problem:
MLDonkey 3.0.1 is out for quite a while, but it is not available in the repo in even rawhide. Also the SRPM needs to be patched to work on Fedora 13 because of the GCC changes.

/usr/bin/ld: src/gtk2/gui/x11/eggtrayicon.o: undefined reference to symbol 'XFlush'
/usr/bin/ld: note: 'XFlush' is defined in DSO /usr/lib/libX11.so.6 so try adding it to the linker command line
/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
File "caml_startup", line 1, characters 0-1:
Error: Error during linking
make: *** [mlgui] Error 2


Version-Release number of selected component (if applicable):
3.0.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Howard Ning 2010-04-13 03:16:05 UTC
BTW, there isn't even a build for Fedora 13.

Comment 2 Peter Lemenkov 2010-04-20 13:16:49 UTC
New mldonkey package is submitted to F-11, F-12 and F-13 stable.


Note You need to log in before you can comment on or make changes to this bug.