Bug 581706 - MLDonkey is outdated and need update
MLDonkey is outdated and need update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mldonkey (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On: 564999
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-12 23:15 EDT by Howard Ning
Modified: 2010-04-20 09:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-20 09:16:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Howard Ning 2010-04-12 23:15:29 EDT
Description of problem:
MLDonkey 3.0.1 is out for quite a while, but it is not available in the repo in even rawhide. Also the SRPM needs to be patched to work on Fedora 13 because of the GCC changes.

/usr/bin/ld: src/gtk2/gui/x11/eggtrayicon.o: undefined reference to symbol 'XFlush'
/usr/bin/ld: note: 'XFlush' is defined in DSO /usr/lib/libX11.so.6 so try adding it to the linker command line
/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
File "caml_startup", line 1, characters 0-1:
Error: Error during linking
make: *** [mlgui] Error 2


Version-Release number of selected component (if applicable):
3.0.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Howard Ning 2010-04-12 23:16:05 EDT
BTW, there isn't even a build for Fedora 13.
Comment 2 Peter Lemenkov 2010-04-20 09:16:49 EDT
New mldonkey package is submitted to F-11, F-12 and F-13 stable.

Note You need to log in before you can comment on or make changes to this bug.