Bug 581718 - Doesn't properly store WEP passphrase in system wireless profile
Summary: Doesn't properly store WEP passphrase in system wireless profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-13 04:42 UTC by Alex Lancaster
Modified: 2010-06-10 19:07 UTC (History)
1 user (show)

Fixed In Version: NetworkManager-0.8.1-0.1.git20100510.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-04 23:50:55 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2010-04-13 04:42:19 UTC
I am trying to setup a system-wide profile with a static IP address that will connect on boot for a wireless connection that is controlled via NetworkManager.  (Note that this connection works just fine when accessed via the "Auto" version of the same access point). I can successfully use the "Edit Connections" to apply the static IP address, set it to start on boot etc.  So my /etc/sysconfig/network-scripts/ifcfg-foobar looks like this:

GATEWAY=192.168.2.1
DNS1=192.168.2.1
DEVICE=wlan0
BOOTPROTO=none
NETMASK=255.255.255.0
TYPE=Wireless
IPADDR=192.168.2.50
IPV6INIT=no
ONBOOT=yes
USERCTL=yes
ESSID="foobar"
MODE=Managed
RATE=auto
NM_CONTROLLED=yes
PREFIX=24
DEFROUTE=yes
NAME="System foobar (wlan0)"
UUID=<obscured>
HWADDR=<obscured>
SECURITYMODE=open
DEFAULTKEY=1

I also entered selected the "WEP 128 bit passphrase" in the drop-down list in the "Wireless Security" tab and entered the correct passphrase.  This generates the file /etc/sysconfig/network-scripts/keys-foobar with contents:

KEY1=<obscured passphrase>

Unfortunately after this is entered and saved, upon leaving "Edit Connections" and reentering it, the "foobar" profile is gone from the list of wireless connections.   Via /var/log/messages I tracked this down to the fact that NetworkManager appeared to be having trouble reading the profile as messages like this appear:

Apr 13 00:16:42 localhost NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-system_roosevelt ... 
Apr 13 00:16:42 localhost NetworkManager:    ifcfg-rh:     error: Invalid WEP key length.

I then translated my WEP passphrase to the full 128-bit key, and re-entered that, and all was well.  So the problem appears to be that the applet or other part of NetworkManager doesn't appear to "translate" or otherwise store the WEP passphrase properly.

This should be fixed to allow saving of system-wide passphrases, or if by design not to save passphrases, then the option to save passphrase for system-wide connections should be disabled and prompt be added that only full WEP passphrases can be accepted.

The current situation is untenable and confusing for users as entering the passphrase for the same connection via the normal gnome keyring works just fine.

Version installed is:

NetworkManager-0.7.998-2.git20100106.fc12.x86_64

Comment 1 Dan Williams 2010-04-23 21:34:35 UTC
Thanks for the report, fixed upstream in:

f20f7294f6f46847bc4c6bb8edeac6fdc810d113

you'll need to change the KEY1 -> KEY_PASSPHRASE1 in the keys file though.  Have to do that because some valid hex/ascii wep keys are also valid passphrases, so we need to use a different tag in the ifcfg file for passphrases and plain keys.

Comment 2 Fedora Update System 2010-04-27 07:56:30 UTC
NetworkManager-0.8.0-8.git20100426.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13

Comment 3 Fedora Update System 2010-04-27 07:57:16 UTC
NetworkManager-0.8.0-8.git20100426.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12

Comment 4 Fedora Update System 2010-04-28 01:15:35 UTC
NetworkManager-0.8.0-8.git20100426.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13

Comment 5 Fedora Update System 2010-04-28 01:20:21 UTC
NetworkManager-0.8.0-8.git20100426.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12

Comment 6 Fedora Update System 2010-04-30 23:49:42 UTC
NetworkManager-0.8.0-9.git20100429.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-9.git20100429.fc13

Comment 7 Fedora Update System 2010-05-04 06:12:44 UTC
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc13

Comment 8 Fedora Update System 2010-05-04 06:14:36 UTC
NetworkManager-0.8.0-11.git20100503.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc12

Comment 9 Fedora Update System 2010-05-04 23:50:15 UTC
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-05-05 09:15:46 UTC
NetworkManager-0.8.0-12.git20100504.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc13

Comment 11 Fedora Update System 2010-05-05 09:18:30 UTC
NetworkManager-0.8.0-12.git20100504.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc12

Comment 12 Fedora Update System 2010-05-06 07:01:48 UTC
NetworkManager-0.8.0-12.git20100504.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-05-07 05:35:19 UTC
NetworkManager-0.7.2.997-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.2.997-1.fc11

Comment 14 Fedora Update System 2010-05-11 06:54:31 UTC
NetworkManager-0.8.1-0.1.git20100510.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc12

Comment 15 Fedora Update System 2010-05-18 21:48:44 UTC
NetworkManager-0.7.2.997-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-06-10 19:06:06 UTC
NetworkManager-0.8.1-0.1.git20100510.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.