Bug 581767 - Support translation of <screen> and <programlisting>
Support translation of <screen> and <programlisting>
Status: CLOSED DUPLICATE of bug 580360
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 03:55 EDT by Raphaël Hertzog
Modified: 2010-11-23 23:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 17:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Raphaël Hertzog 2010-04-13 03:55:12 EDT
It's very common for <screen> to include localized text that is output by the commands that are run. Thus I would like the content of <userinput> and <computeroutput> to be included in the PO files so that translators can update the strings to match those that would be output in their locale.

<programlisting> is more discutable by I tend to put descriptive comments in the native language so it would also be nice to be able to translate those elements too.

Following that logic, when this new option is enabled, those tag should not be forbidden inside <para> and instead the content of para should simply be split (before/afer the verbatim text).
Comment 1 Jeff Fearn 2010-04-13 17:11:13 EDT
Note: There is a discussion about this on the publican mail list, please feel free to join in!

*** This bug has been marked as a duplicate of bug 580360 ***

Note You need to log in before you can comment on or make changes to this bug.