Bug 58178 - Bad: cyg_type.inc file is missing
Summary: Bad: cyg_type.inc file is missing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: ConfigTool (Show other bugs)
(Show other bugs)
Version: 1.3.1
Hardware: arm7 Linux
medium
medium
Target Milestone: ---
Assignee: Julian Smart
QA Contact: eCos bugs internal list
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-10 16:38 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 19:17:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-01-10 16:38:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Config Tool 2.08 has a bug when loading self generated file:
mlt_arm_edb7211_ram.ldi


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start Config Tool, set for Cirrus Logic developement board, ad Networking
2. Include in eCos HAL->Source level debugging support->Include GDB Stubs in HAL
3.Start Build->Library
	

Actual Results:  Last messages are

...
make[1]: Leaving directory `/ecos-c/0eC/net2_build/hal/arm/arch/v1_3_1'

In file included from =
/ecos-c/Programme/REDHAT~1/eCos/packages/hal/arm/arch/v1_3_1/src/arm.ld:1=
62:

make: Leaving directory `/ecos-c/0eC/net2_build'

/ecos-c/0eC/net2_install/include/pkgconf/mlt_arm_edb7211_ram.ldi:5: =
cyg/infra/cyg_type.inc: No such file or directory

make[1]: *** [/ecos-c/0eC/net2_install/lib/target.ld] Error 1

make: *** [build] Error 2



Expected Results:  correct library generation

Additional info:

Comment 1 Jonathan Larmour 2002-01-10 19:17:15 UTC
Actually this problem is because you are using the 1.3.1 repository with a newer
configuration tool. Either use the anonymous CVS repository, or create the file
packages/infra/v1_3_1/include/cyg_type.inc yourself as an empty file.

This will be irrelevant when 2.0 comes out.




Note You need to log in before you can comment on or make changes to this bug.