Bug 58182 - kickstart fails when partitions are specified with cylinders
kickstart fails when partitions are specified with cylinders
Status: CLOSED DUPLICATE of bug 55138
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 12:44 EST by Subhendu Ghosh
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 15:52:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2002-01-10 12:44:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I have 30 systems with Windows XP on them.  Am trying to install RH7.2 via
Kickstart.  Installed on test system from CD. Generated base ks.cfg via
ksconfig, modified partitioning scheme based on existing cylinders values from
fdisk.  All the disks in the 30 systems are identical.
Anaconda complains that not enough disk space has been allocated for root, boot,
swap, and var partitions.

Is there a way to turn off the space requirement verification.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot from cd with "linux ks"
2.dhcp succeeds, nfs directory mounted
3.anaconda starts
4.successful probes for video, monitor and mouse
5.Error message on partion not being created.
6.On tty3 - the error messages talk about swap being 0 and root is less than 250MB	

Actual Results:  system prompts for reboot

Expected Results:  disks should be partitioned and package install should proceed

Additional info:

=====ks.cfg=====

lang en_US
langsupport en_US
keyboard us
mouse logimmanps/2
timezone --utc America/New_York
rootpw --iscrypted $1$MUmQFUQN$e56CS/MfW.jzKMrnJ29If/
reboot
text
bootloader --location=mbr 
install
nfs --server 10.10.0.1 --dir /usr/local/archive/redhat/
zerombr yes
clearpart --all --initlabel drives=hda
part /boot  --fstype ext3  --ondisk hda  --start 1 --end 13
part / --fstype ext3   --ondisk hda  --start 14 --end 395
part /var --fstype ext3 --ondisk hda  --start 396 --end 522
part swap --fstype swap --ondisk hda --start 523 --end 652
part /opt --fstype ext3 --ondisk hda --start 653 --end 4865
network --bootproto dhcp
auth  --useshadow  --enablemd5  --enablenis --nisdomain endlab-cluster 
--nisserver 10.10.0.1
firewall --disabled 
skipx
#xconfig  --depth 16 --resolution 1024x768 --defaultdesktop=GNOME --card "Matrox
Millennium G450"  --monitor "GDM-5402"
%packages

==== fdisk output from cd install====
Command (m for help): p

Disk /dev/hda: 255 heads, 63 sectors, 4865 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        13    104391   83  Linux
/dev/hda2            14       395   3068415   83  Linux
/dev/hda3           396       522   1020127+  83  Linux
/dev/hda4           523      4865  34885147+   5  Extended
/dev/hda5           523       652   1044193+  82  Linux swap
/dev/hda6           653      4865  33840891   83  Linux
Comment 1 Subhendu Ghosh 2002-01-15 09:18:14 EST
The error seems to be comming from the following in partitioning.py
It looks like partitioning specified with cylinders does not calculate the space
realized hence the routine fails on all checks.


(line 562 in J. Katz's modified partioning.py as posted on the web.  same
section exists in the cdrom rpm.)

# this function is called at the end of partitioning so that we
# can make sure you don't have anything silly (like no /, a really small /,
# etc).  returns (errors, warnings) where each is a list of strings or None
# if there are none
# if baseChecks is set, the basic sanity tests which the UI runs prior to
# accepting a partition will be run on the requests
def sanityCheckAllRequests(requests, diskset, baseChecks = 0):
    checkSizes = [('/usr', 250), ('/tmp', 50), ('/var', 50),
                  ('/home', 100), ('/boot', 20)]
    warnings = []
    errors = []

Comment 2 Michael Fulbright 2002-01-23 16:14:28 EST

*** This bug has been marked as a duplicate of 55138 ***

Note You need to log in before you can comment on or make changes to this bug.