Bug 581832 - RHN Satellite doesn't complain if packages are missing during 'Package Profile Sync' for 32bit client systems
RHN Satellite doesn't complain if packages are missing during 'Package Profil...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Šimon Lukašík
:
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-04-13 07:41 EDT by Vishal Gaikwad
Modified: 2011-03-17 10:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause Bug in comparison of package metadata Consequence When syncing systems or profiles, missing packages were not correctly identified. Result Correct system/profile sync, with correct identification of missing packages
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vishal Gaikwad 2010-04-13 07:41:45 EDT
Description of problem:
Scheduling a Package Profile sync on 32bit systems doesn't complain about missing packages if the packages are not available in any channel. It continues to schedule package profile sync. But, if you have multi-lib systems wherein packages or both the archs are selected in Profile sync, it correctly reports the missing packages.

Version-Release number of selected component (if applicable):
RHNS 530

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL5.4 (i386) on two systems (A and B) and register them to Satellite with provisioning.
2. Update a package on SystemA manually and that version of package doesn't exist on the base channel yet. E.g. We manually update krb5-libs-1.6.1-36.el5_5.2, while the latest version of our rhel5 base channel is still krb5-libs-1.6.1-36.el5_4.1 because we haven't sync the Satellite with RHN timely.
3. Then on the Satellite, do a profile comparison on system B with system A. And it will find that system A has a newer krb5-libs then system B.
4. Then do the profile sync. Satellite will schedule a job that "Replace krb5-libs-1.6.1-36.el5_4.1 with krb5-libs-1.6.1-36.el5_5.2". (The problem is, actually we DON'T have krb5-libs-1.6.1-36.el5_5.2 in our base channel)
  
Actual results:
No missing packages are reported, even if the packages in the Sync are not available in any channel that is sync'ed on the RHN Satellite server.

Expected results:

It should report missing packages and should redirect to rhn/systems/details/packages/profiles/MissingPackages.do showing:

Missing Packages
The following packages are listed in the package profile which you have selected to sync

Package 	Channels
<<package_name>> 	None
Comment 5 Tomas Lestach 2010-12-06 15:15:11 EST
Nice catch.

Fixed in spacewalk.git: 7177f0eecd7e801a2d4fb54543f0e0e1983c6049
Comment 9 Tomas Lestach 2011-02-14 08:36:14 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Bug in comparison of package metadata

Consequence
When syncing systems or profiles, missing packages were not correctly identified.

Result
Correct system/profile sync, with correct identification of missing packages
Comment 10 Šimon Lukašík 2011-02-24 05:11:29 EST
Taking QA contact.
Comment 11 Šimon Lukašík 2011-02-24 08:39:34 EST
Changing to VERIFIED.

Testing procedure:
- I have followed the reproducer from comment 0, but not on single
package level but with whole distributions.
- I have Satellite with synced rhel55 and to clients rhel54 and rhel56
- With old errata packages: profile sync from rhel56 to rhel54 failed
with unsatisfied dependencies. (basically all packages available in
subscribed channel was scheduled for sync, regardless on version
available in satellite.
- With new errata packages: Same profile sync scheduled only 
update only for packages which were in exact version available in
registered channels. Rest of the packages, were excluded and reported
on webui, before submitting. Well done!
- I have verified it with both profile sync against machine & profile
sync against stored profile. (resulting package profile matches for
both case)

Verified against:
spacewalk-java-1.2.39-36.el5sat
Comment 12 errata-xmlrpc 2011-03-17 10:11:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0362.html

Note You need to log in before you can comment on or make changes to this bug.