Bug 581848 - Log file with exception of failed to deploy jbossws.sar
Summary: Log file with exception of failed to deploy jbossws.sar
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server
Version: 3.0.0
Hardware: All
OS: Linux
high
low vote
Target Milestone: ---
: ---
Assignee: John Sanda
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks: rhq_triage jon-sprint10-bugs
TreeView+ depends on / blocked
 
Reported: 2010-04-13 12:26 UTC by Rajan Timaniya
Modified: 2010-05-19 17:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-19 17:28:18 UTC


Attachments (Terms of Use)
log file (17.88 KB, text/x-log)
2010-04-13 12:26 UTC, Rajan Timaniya
no flags Details

Description Rajan Timaniya 2010-04-13 12:26:07 UTC
Created attachment 406221 [details]
log file

Description of problem:
Log file with the exception for deploy failed for jbossws.sar on JON Server.

(Reference: https://jira.jboss.org/jira/browse/JBWS-2821)

Version-Release number of selected component (if applicable):
jon build #88 Revision: 10607  (http://hudson-qe.rhq.rdu.redhat.com:8080/job/jon/88/)

How reproducible:
Always

Steps to Reproduce:
1) Install JON on Oracle or Postgres and start server
2) Verify log file (../jon-server-2.4.0-SNAPSHOT/logsrhq-server-log4j.log) for jbossws.sar deploy 
  
Actual results:
Failed to deploy jbossws.sar with the exception:
[org.jboss.deployment.MainDeployer] Could not initialise deployment: file:../jon-server-2.4.0-SNAPSHOT/jbossas/server/default/deploy/jbossws.sar/
org.jboss.deployment.DeploymentException: Failed to find META-INF/jboss-service.xml for archive jbossws.sar

Additional info:
Please refer attached log file.

Comment 1 Charles Crouch 2010-04-27 17:49:37 UTC
Why is jbossws.sar even being deployed? How did this behave in 2.3? Since we're not supporting WS access in 2.4, can this service just be removed/disabled?

Comment 2 Charles Crouch 2010-05-18 04:55:04 UTC
First off lets check if this is still a problem, and if so make sure it wasnt a problem in 2.3.1

Comment 3 John Sanda 2010-05-19 15:32:28 UTC
I just deployed jbossws on a JON 2.3.1 installation without error. I verified that the RHQ web service is up by hitting http://localhost.localdomain:7080/rhq-rhq-enterprise-server-ejb3/WebservicesManagerBean?wsdl. I will investigate whether or not we can remove jbossws.

Comment 4 John Sanda 2010-05-19 15:32:39 UTC
I just deployed jbossws on a JON 2.3.1 installation without error. I verified that the RHQ web service is up by hitting http://localhost.localdomain:7080/rhq-rhq-enterprise-server-ejb3/WebservicesManagerBean?wsdl. I will investigate whether or not we can remove jbossws.

Comment 5 John Sanda 2010-05-19 17:28:18 UTC
I just deployed jbossws on an RHQ server built from my current HEAD (8d1c051fbb07765ea3e746754ae61aabe2257a12) without error. I verified that the RHQ web service is up by hitting http://localhost.localdomain:7080/rhq-rhq-enterprise-server-ejb3/WebservicesManagerBean?wsdl. 

And jbossws.sar is not deployed by default. It is deployed as jbossws.sar.rej; so, it is in fact disabled by default. I am going to close this bug out since I have not been able to produce any errors and since jbossws is disabled by default.


Note You need to log in before you can comment on or make changes to this bug.