Bug 581911 - SELinux is preventing /bin/mailx access to a leaked inotify file descriptor.
Summary: SELinux is preventing /bin/mailx access to a leaked inotify file descriptor.
Keywords:
Status: CLOSED DUPLICATE of bug 518998
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:804cc400e0c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-13 15:29 UTC by ssabchew
Modified: 2015-02-01 22:51 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-05 12:27:42 UTC


Attachments (Terms of Use)

Description ssabchew 2010-04-13 15:29:10 UTC
Summary:

SELinux is preventing /bin/mailx access to a leaked inotify file descriptor.

Detailed Description:

[mailx has a permissive type (sendmail_t). This access was not denied.]

SELinux denied access requested by the mailx command. It looks like this is
either a leaked descriptor or mailx output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the inotify. You should generate a bugzilla on selinux-policy, and it will get
routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:sendmail_t:s0-s0:c0.c1023
Target Context                system_u:object_r:inotifyfs_t:s0
Target Objects                inotify [ dir ]
Source                        mailx
Source Path                   /bin/mailx
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           mailx-12.4-3.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-108.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.10-90.fc12.x86_64 #1 SMP Tue Mar 23
                              09:47:08 UTC 2010 x86_64 x86_64
Alert Count                   10
First Seen                    Wed 31 Mar 2010 04:36:15 PM EEST
Last Seen                     Sun 11 Apr 2010 01:24:32 PM EEST
Local ID                      0144704f-3a0b-44ba-bf88-f6de1eb768a4
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1270981472.621:9): avc:  denied  { read } for  pid=2724 comm="mailx" path="inotify" dev=inotifyfs ino=1 scontext=system_u:system_r:sendmail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1270981472.621:9): avc:  denied  { write } for  pid=2724 comm="mailx" path="/var/run/abrt.lock" dev=dm-1 ino=400 scontext=system_u:system_r:sendmail_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1270981472.621:9): arch=c000003e syscall=59 success=yes exit=0 a0=884120 a1=8738b0 a2=7ffff7268f98 a3=7ffff7268820 items=0 ppid=2446 pid=2724 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="mailx" exe="/bin/mailx" subj=system_u:system_r:sendmail_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,mailx,sendmail_t,inotifyfs_t,dir,read
audit2allow suggests:

#============= sendmail_t ==============
allow sendmail_t abrt_var_run_t:file write;
allow sendmail_t inotifyfs_t:dir read;

Comment 1 Daniel Walsh 2010-04-13 15:42:20 UTC
Abrt should not leak.

Comment 2 Nikola Pajkovsky 2010-05-05 12:27:42 UTC

*** This bug has been marked as a duplicate of bug 518998 ***


Note You need to log in before you can comment on or make changes to this bug.