Bug 581948 - F12 preupgrade fills /boot partition
F12 preupgrade fills /boot partition
Status: CLOSED DUPLICATE of bug 573451
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 13:07 EDT by Dick Franks
Modified: 2010-04-16 06:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-16 06:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dick Franks 2010-04-13 13:07:33 EDT
Description of problem:
Attempt to upgrade F12 to F13beta using preupgrade fails because downloaded /boot/upgrade/install.img overflows /boot partition.

Version-Release number of selected component (if applicable):

# yum info preupgrade
Loaded plugins: presto, refresh-packagekit
Installed Packages
Name       : preupgrade
Arch       : noarch
Version    : 1.1.4
Release    : 1.fc12
Size       : 347 k
Repo       : installed
From repo  : updates
Summary    : Prepares a system for an upgrade
URL        : https://fedorahosted.org/preupgrade/


How reproducible: 100%


Steps to Reproduce:
1. su - root
2. cd /tmp
3. yum install preupgrade # (if not already present)
4. preupgrade
5. select F13
  
Actual results:
preupgrade terminates when out of space on /boot partition.

Expected results:
upgrade to F13beta

Additional info:
F12 installation built using default disk layout.

Uninstalling old kernels made no difference

# df -lk
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/vg_staid176508-lv_root
                      74695856   7605932  63295596  11% /
tmpfs                   506820       444    506376   1% /dev/shm
/dev/sda1               198337    198313         0 100% /boot


# ls -Rlt /boot
/boot:
total 18253
drwxr-xr-x. 2 root root     1024 2010-04-13 17:03 upgrade
drwxr-xr-x. 2 root root     1024 2010-04-13 16:56 grub
-rw-r--r--. 1 root root 12860855 2010-04-07 18:41 initramfs-2.6.32.10-90.fc12.x86_64.img
-rw-r--r--. 1 root root  2099548 2010-03-23 10:01 System.map-2.6.32.10-90.fc12.x86_64
-rw-r--r--. 1 root root   101075 2010-03-23 10:01 config-2.6.32.10-90.fc12.x86_64
-rwxr-xr-x. 1 root root  3604032 2010-03-23 10:01 vmlinuz-2.6.32.10-90.fc12.x86_64
drwxr-xr-x. 3 root root     1024 2009-12-24 12:12 efi
drwx------. 2 root root    12288 2009-12-24 11:57 lost+found

/boot/upgrade:
total 173918
-rw-r--r--. 1 root root 143750144 2010-04-13 17:05 install.img
-rw-r--r--. 1 root root  30546532 2010-04-12 19:08 initrd.img
-rw-r--r--. 1 root root   3789568 2010-04-12 19:08 vmlinuz

/boot/grub:
total 305
-rw-------. 1 root root    740 2010-04-13 16:56 grub.conf
-rw-r--r--. 1 root root 125424 2009-12-24 12:28 stage2
-rw-r--r--. 1 root root  14864 2009-12-24 12:28 e2fs_stage1_5
-rw-r--r--. 1 root root  16120 2009-12-24 12:28 reiserfs_stage1_5
-rw-r--r--. 1 root root    512 2009-12-24 12:28 stage1
...
Comment 1 Dan Horák 2010-04-16 06:26:12 EDT

*** This bug has been marked as a duplicate of bug 573451 ***

Note You need to log in before you can comment on or make changes to this bug.