Bug 581961 - publican inserts '-' character in screen tags if there is a whitespace and then a special character
publican inserts '-' character in screen tags if there is a whitespace and th...
Status: CLOSED DUPLICATE of bug 577068
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 13:35 EDT by Deon Ballard
Modified: 2010-11-23 23:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 17:15:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
release notes (221.85 KB, application/pdf)
2010-04-13 13:35 EDT, Deon Ballard
no flags Details

  None (edit)
Description Deon Ballard 2010-04-13 13:35:43 EDT
Created attachment 406307 [details]
release notes

I have publican 1.6.2-0.el5.

publican is inserting a - character in front of every special character in the <screen> tags in the PDF. For example, I have this:

<screen><userinput>/usr/sbin/alternatives --config java</userinput> &nbsp;

There are 2 programs which provide 'java'.

  Selection    Command
-----------------------------------------------
*+ 1           /usr/lib/jvm/jre-1.5.0-ibm/bin/java
   2           /usr/lib/jvm/jre-1.4.2-sun/bin/java

Enter to keep the current selection[+], or type selection number: 1

<userinput>/usr/sbin/alternatives --config javac</userinput> &nbsp;

There are 2 programs which provide 'javac'.

  Selection    Command
-----------------------------------------------
   1           /usr/lib/jvm/java-1.5.0-bea/bin/javac
*+ 2           /usr/lib/jvm/java-1.5.0-ibm/bin/javac</screen>


And it renders it as this in the PDF:

=========================================================================

/usr/sbin/alternatives ---config java
There are 2 programs which provide -'java'.
  Selection    Command
-----------------------------------------------
*+ 1           -/usr/lib/jvm/jre-1.5.0-ibm/bin/java
   2           -/usr/lib/jvm/jre-1.4.2-sun/bin/java
Enter to keep the current selection[+], or type selection number: 1

/usr/sbin/alternatives ---config javac
There are 2 programs which provide -'javac'.
  Selection    Command
-----------------------------------------------
   1           -/usr/lib/jvm/java-1.5.0-bea/bin/javac
*+ 2           -/usr/lib/jvm/java-1.5.0-ibm/bin/javac


=========================================================================


This is on page 8 of the RHCS release notes.
Comment 1 Jeff Fearn 2010-04-13 17:15:38 EDT

*** This bug has been marked as a duplicate of bug 577068 ***

Note You need to log in before you can comment on or make changes to this bug.