This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 58197 - Gnome locks machine
Gnome locks machine
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 17:38 EST by Jason Montleon
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Montleon 2002-01-10 17:38:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When running Gnome on RedHat 7.2 it locks up the machine.  KDE works fine with 
the same configuration.  The system is an HP Vectra VL6 Series 8 running at 350 
MHz, 128 MB RAM, a 10/100 82559 InBusiness NIC, and a built-in AGP MGA 100 
Productiva video card with 4MB RAM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run startx to start Gnome desktop
	

Actual Results:  Gnome locks up the machine so that mouse and keyboard are 
totally unresponsive

Expected Results:  Gnome desktop should start normally

Additional info:

I built a 2.4.17 kernel and this resolved the problem, though it persists with 
either kernel provided for RedHat 7.2 via the RPM packages

lspci -v output:
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev 
02)
	Flags: bus master, medium devsel, latency 64
	Memory at f8000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 02) 
(prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 128
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	Memory behind bridge: fe000000-febfffff
	Prefetchable memory behind bridge: f6000000-f6ffffff

00:04.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
	Flags: bus master, medium devsel, latency 0

00:04.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01) (prog-if 80 
[Master])
	Flags: bus master, medium devsel, latency 64
	I/O ports at fcf0 [size=16]

00:04.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01) (prog-if 
00 [UHCI])
	Flags: medium devsel, IRQ 5
	I/O ports at fcc0 [disabled] [size=32]

00:04.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
	Flags: medium devsel, IRQ 9

00:0b.0 Ethernet controller: Intel Corporation 82559 InBusiness 10/100 (rev 08)
	Subsystem: Intel Corporation 82559 InBusiness 10/100
	Flags: bus master, medium devsel, latency 64, IRQ 5
	Memory at fecff000 (32-bit, non-prefetchable) [size=4K]
	I/O ports at fc40 [size=64]
	Memory at fed00000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at <unassigned> [disabled] [size=1M]
	Capabilities: [dc] Power Management version 2

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G100 [Productiva] 
AGP (rev 02) (prog-if 00 [VGA])
	Subsystem: Matrox Graphics, Inc. MGA-G100 AGP
	Flags: bus master, stepping, medium devsel, latency 64, IRQ 11
	Memory at f6000000 (32-bit, prefetchable) [size=16M]
	Memory at febf8000 (32-bit, non-prefetchable) [size=16K]
	Memory at fe000000 (32-bit, non-prefetchable) [size=8M]
	Capabilities: [dc] Power Management version 1
	Capabilities: [f0] AGP version 1.0
Comment 1 Jason Montleon 2002-01-14 07:28:27 EST
Things I have tried to do to clarify what is causing the problem included:
1.) Upgraded to the latest BIOS provided by HP which had no effect

2.) Tried launching Gnome through VNC; this had no effect.  I'm not sure the 
inner workings of X-Windows, and I guess my intent was to try and clear X-
Windows, as I don't think it uses X-Windows, but as I said, I'm not sure at all 
about this statement.

3.) Turned off Power Management and suspend features in the BIOS.

4.) Tried different resolutions/color settings.  KDE worked no matter the 
settings, but Gnome would lock up the machine, though it remained pingable.

5.) Removed the sound card in case of conflict or incompatibility which had no 
effect.  After this I formatted the drive and reinstalled the machine clean 
again, wondering if perhaps something went wrong during the install.  I tried 
starting up Gnome and again the same thing happened so I went on with 
troubleshooting the problem.

6.) Went into /root/.gnome/default.wm and changed the Window Manager to twm 
instead of Sawfish to no effect. 

7.) Upgraded the kernel and all other updates available via up2date, to no 
effect 

8.) Changed NIC card slot (only card plugged in now), to no effect 

9.) Replaced NIC card with a different model, to no effect 

10.) Someone on the Enigma mailing list suggested that it may be an W-Windows 
or Kernel problem.  I was unable to try a different video card and dicern 
whether that was the culprit so I built a 2.4.17 kernel downloaded and compiled 
from www.kernel.org and this resolved the problem.
Comment 2 Bugzilla owner 2004-09-30 11:39:20 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.