Bug 58201 - Host name lookup failures in sendmail
Host name lookup failures in sendmail
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-01-10 18:36 EST by Steve Wardell
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-08 04:42:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steve Wardell 2002-01-10 18:36:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Host name lookup failures occur intermittently which causes some messages to 
remain in queue. Some process through and some don't. Nslookups all work fine. 
Name servers appear to have no problem.

Running sendmail RPM version 8.11.6-3

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start sendmil
2.Intermittently some outgoing mail has host lookup failures.


Actual Results:  Mail remains in queue and is not send. Bouncing sendmail 
causes some messages to go through.

Expected Results:  All messages get sent except when there really is a problem 
with hostlookup.

Additional info:
Comment 1 Steve Wardell 2002-01-10 23:13:39 EST
Ok, problem's fixed. I think it was DNS. I tried all our DNS servers but all 
had problems with getting nameserver lookup deferred with sendmail. So I just 
installed a DNS cache server on the machine, and now it's all perfect. 
Basically, it's a DNS server that runs on and then I pointed 
my /etc/resolv.conf to use that local server. The local server uses our office 
DNS servers, but it's more robust and also caches the results. As soon a I put 
this thing on, all the pending email whooshed right through. Could this still 
be looked into with that in mind?
Comment 2 Need Real Name 2002-03-08 04:41:57 EST
I have the exact same problem (host name lookup failures), but (so far) only
with mail going to hotmail.com. And, as far as I can tell, all mail going to
hotmail.com is affected:

   [hotdog@mona ~]$ /usr/sbin/sendmail -bp
                   /var/spool/mqueue (11 requests)
   ----Q-ID---- --Size-- -----Q-Time-----
   g272kX320367     2249 Thu Mar  7 03:54 MAILER-DAEMON
                    (Deferred: Name server: mx07.hotmail.com.: host name lookup
   [...9 more emails going to various hotmail.com-addresses...]
   g24FZu225755      191 Mon Mar  4 16:35 <bbbbb@fffff.info>
         8BITMIME   (Deferred: Name server: mx06.hotmail.com.: host name lookup
   [hotdog@mona ~]$ 

[Email-adresses have been obscured to protect the innocent]

However, I have no problem looking up hotmail.com, both the normal way and with

   [hotdog@mona ~]$ nslookup
   Default Server:  dns1.cybercity.dk
   > hotmail.com
   Server:  dns1.cybercity.dk
   Non-authoritative answer:
   Name:    hotmail.com
   > set type=mx
   > hotmail.com
   Server:  dns1.cybercity.dk
   Non-authoritative answer:
   hotmail.com     preference = 5, mail exchanger = mx10.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx11.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx12.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx13.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx14.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx15.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx01.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx02.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx04.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx05.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx06.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx07.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx08.hotmail.com
   hotmail.com     preference = 5, mail exchanger = mx09.hotmail.com
   Authoritative answers can be found from:
   hotmail.com     nameserver = ns1.hotmail.com
   hotmail.com     nameserver = ns2.hotmail.com
   hotmail.com     nameserver = ns3.hotmail.com
   hotmail.com     nameserver = ns4.hotmail.com
   mx10.hotmail.com        internet address =
   mx11.hotmail.com        internet address =
   mx12.hotmail.com        internet address =
   mx13.hotmail.com        internet address =
   mx14.hotmail.com        internet address =
   mx15.hotmail.com        internet address =

Also, I can telnet directly to mx02.hotmail.com:

   [hotdog@mona ~]$ telnet mx02.hotmail.com 25
   Connected to mx02.hotmail.com.
   Escape character is '^]'.
   220-HotMail (NO UCE) ESMTP server ready at Fri, 08 Mar 2002 01:26:57 -0800 
   220 ESMTP spoken here
   221 Service closing transmission channel
   Connection closed by foreign host.
   [hotdog@mona ~]$ 

Only sendmail can't seem to make the connection :-(.

For what it's worth, I'm using RedHat 7.0 (kernel 2.2.19-7.0.12 on an i486) with
Comment 3 Florian La Roche 2002-03-10 02:45:17 EST
Looks all more like Internet problems or DNS issues. Please reopen if you can
point at any wrong code within sendmail.


Florian La Roche
Comment 4 Steve Wardell 2002-04-03 12:29:39 EST
This happens on Redhat 7.2 AND on skipjack. DNS failures are occurring, but dig,
host, etc resolve the domains fine. There seems to be a problem in sendmail.
Comment 5 Need Real Name 2002-04-03 17:02:39 EST
I too solved the problem by installing a DNS caching server on our system. The 
problem appears not to be with sendmail as such, but with hotmail being 
_really_ impatient at some times.

Try to telnet to one of the hotmail-mx-servers on port 25 and pretend to want 
to send an email. Unless you cut'n'paste your commands, you'll get 
disconnected - as far as I can tell only for being too slow.

Sendmail appears to be make some dns-lookup(s) after it connects to 
mx__.hotmail.com (or any other server), and the dns-lookup)s= needs to happen 
really fast or hotmail will disconnect the sendmail-process. Therefore, a local 
DNS caching server will help. Well, at least from the second time, you try to 
send an email to hotmail, since the caching server still needs to make a lookup 
the first time :-).
Comment 6 Need Real Name 2002-04-03 18:35:12 EST
I installed a DNS caching software to solve the problem. In this case, the 
problem is related to sendmail on the Linix machine sending out. The example 
given of Hotmail.com may be unrelated. By the time your Linux machine has been 
able to connect to hotmail.com's MX servers on port 25, it's already completed 
the DNS lookup. The problem is getting the DNS lookup to work succesfully. Once 
you've made the port 25 connection, everything's fine.

Note You need to log in before you can comment on or make changes to this bug.