Bug 58205 - 'ip link set eth1 up' hangs at boot time
'ip link set eth1 up' hangs at boot time
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: iproute (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 19:15 EST by Olivier de Mirleau
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 07:48:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuraion file of dhcpd (499 bytes, text/plain)
2002-01-10 19:17 EST, Olivier de Mirleau
no flags Details
output of 'ipchains -L -v' (1.48 KB, text/plain)
2002-01-10 19:21 EST, Olivier de Mirleau
no flags Details
Output of 'lspci -v' (2.82 KB, text/plain)
2002-07-01 13:42 EDT, Olivier de Mirleau
no flags Details

  None (edit)
Description Olivier de Mirleau 2002-01-10 19:15:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
-I can't get either of my two ethernet interfaces up at boot time:
  The system hangs during boot when I do that.
-However I can start them manually after boot by using the 'ifup ethN' command.
-The tentative workaround of running say 'ifup eth1' from
 /etc/rc.d/rc.local also halts the system.
-Since the system is halted I have to reset it, after which my filesystem
  turns out corrupted: The file /var/lib/dhcpd/dhcpd.leases shows up as
  an unattached inode and ends up in /lost+found after running fsck.
-I have been tracing the network scripts at boot time, finding out that
  bringing up my eth0 card (BOOTPROTO=dhcp) makes the
  system halt in the call '/sbin/dhcpcd -n -R eth0', whereas the eth1
  card (no dhcp) halts the system during 'ip link set eth1 up'.

I presume the latter (ip) is the more basic executable. The -V option returns
'ip utility, iproute2-ss001007', and it came with rpm package iproute-2.2.4-14.

Actually I don't know if this is bug or if I'm doing something wrong.

Version-Release number of selected component (if applicable):
2.2.4-14

How reproducible:
Always

Steps to Reproduce:
1. Set ONBOOT=yes in /etc/sysconfig/network-scripts/ifcfg-eth1,
   OR add line 'ifup eth0' in /etc/rc.d/rc.local
2. Reboot
 

Actual Results:  My system hangs every time at "Bringing up interface eth1"

Expected Results:  It shouldn't have. It should have brought up eth1 and
continued booting.

Additional info:

I'm also running dhcpd and firewall rules at boot. Configuration file dhcpd.conf
and output
of ipchains -L -v attached.
Comment 1 Olivier de Mirleau 2002-01-10 19:17:33 EST
Created attachment 42253 [details]
Configuraion file of dhcpd
Comment 2 Olivier de Mirleau 2002-01-10 19:21:56 EST
Created attachment 42254 [details]
output of 'ipchains -L -v'
Comment 3 Phil Knirsch 2002-02-24 05:20:57 EST
OK, my first thought would be that something is broken with the initscripts. If
you could check the following things and/or provide the following information i
might be able to be of assistance:

1) Install the latest errata version of initscripts available via
http://www.redhat.com/support/errata/RHBA-2002-022.html. It fixes quite a few
network related problems.

2) If that doesn't help i need to know your hardware setup, mainly the exact
specs of your network cards. Additionally the rpm version numbers of the kernel,
initscripts, dhcp and initscripts are required.

Read ya, Phil
Comment 4 Olivier de Mirleau 2002-02-24 12:19:11 EST
Hi Phil, thanks for your time. I ran up2date resulting in new
initscripts, but I still have the same problem. The package versions that
you asked for are currently the following:
(rpm -qa | grep kernel, initscript, dhcp)

kernel-headers-2.4.7-10
kernel-2.4.7-10
initscripts-6.43-1
dhcp-2.0pl5-8
dhcpcd-1.3.18pl8-13

As for the two ethernet cards:
3Com Eth.XL 3C905B-TX 10/100 NM
Twister NTW-10/100P
(Hope that makes any sense to you, I had these
names written in a file, I think I probably copied
them from the purchase bills).

The following might also be relevant:
1. I have a RH6.1 distribution deployed on another
    disk partition of the same computer,
    which doesn't have this problem.
2. I did some other (network-only) installations of the RH7.2 cd, still on the
    same computer. They also suffer from the same problem,
    but I a saw difference between two installations:
    a. An intallation with high firewall security gave the
        same problem as noted above.
    b. An intallation with no firewall security behaved worse:
         Ifup not only crashed at boot-time but also when
         ran manually from a shell.
    Note that all these different 7.2 installations were booted using
    the same kernel: I.e., referring to disk partitions A, B and C,
    A has a kernel, B and C are different installations.
     LiloBoot1: bootkernel on A, /=B, /boot=A
     LiloBoot2: bootkernel on A, /=C
     (because C starts at high cylinder, I couldn't boot from C,
      so I just reused A).
3. Also note that bringing up ethN has actually NEVER
    worked correctly for me and 7.2:
     I install 7.2-> I boot it-> It crashes -> I reset ->
     I boot another partition -> I put ONBOOT=no in ifcfg-ethN ->
     I boot -> It doesn't crash
4. By 'crash' I mean that no keystroke seems to have any effect,
    including ctrl-alt-delete. Also I need only press my on/off switch
    for a very short period of time to switch my computer off. Under
    normal circumstances this is only the case after issuing the 'halt'
    command. If I press my on/off button under normal circumstances
    nothing happens unless I hold it for five seconds. So it would seem
    that the crash moves the machine to a halted state.
5.  Since the problem occurs with the two different cards, it might
     be a motherboard thing: I have a Compaq presario 5476. But then
     again, the 6.1 distribution has no problems.

I guess that's what I can think of at the moment,
hope there's a clue for you somewhere!,
Ciao,
Olivier
Comment 5 Phil Knirsch 2002-06-19 07:49:08 EDT
Hi Olivier!

Sorry for not responding earlier, but i was terribly swamped with work.

This really sounds very strange, especially that even after fresh installs the
problems persits and gets worse with no firewall rules set at all.

Could you do a

lspci -v

on that machine and attache the output here?

Also, did you give 7.3 a shot, especially the new kernel? It might be a driver
problem as it seems to really badly hang your machine...

Read ya, Phil
Comment 6 Olivier de Mirleau 2002-07-01 13:42:15 EDT
Created attachment 63266 [details]
Output of 'lspci -v'
Comment 7 Olivier de Mirleau 2002-07-01 13:48:30 EDT
Hi Phil, thanks for your time, I attached the output you asked for &
will upgrade to 7.3 in the next few days. I'll keep you posted,
Bye, Olivier

Comment 8 Olivier de Mirleau 2002-08-11 09:26:16 EDT
Hi Phil, I gave up, 7.3 doesn't work either. I recently bought a new computer
and don't have any problems with that one. I'll give the compaq to my mother,
she's not very likely to post bugs here, so we can consider the bug closed!

Thanks for your time spent!,
Olivier
Comment 9 Phil Knirsch 2003-06-20 07:48:50 EDT
OK, closing as worksforme (which it does. ;-).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.