Bug 582058 - hang of several minutes at install of bind
hang of several minutes at install of bind
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 21:00 EDT by Tom Horsley
Modified: 2013-04-30 19:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:12:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2010-04-13 21:00:37 EDT
Description of problem:

Just tried installing from x86_64 f13-beta dvd iso image. When anaconda
says "installing bind-9.7.0-0.14.rc2.fc13.x86_64" it hangs for several
minutes, long enough that I start poking around in Ctrl-Alt-FN terminals
to see if I can see anything. At the end of one of the screens I find
during this process is this same message I see in the anaconda.log file:

17:23:05 INFO    : Preparing to install packages
17:23:47 WARNING : /usr/lib/anaconda/iw/progress_gui.py:67: GtkWarning: Failed to set text from markup due to error parsing markup: Error on line 2 char 32: Element 'markup' was closed, but the currently open element is 'NAME'
  self.infolabel.set_markup(txt)

17:40:54 INFO    : moving (1) to step postinstallconfig

But the time I cycled back around to the install gui window, the install
process finally picked back up and other packages were installing. I have
no idea if it just finally timed out or if switching vterms triggered something
that made it start going again.

Version-Release number of selected component (if applicable):

Whatever was on the f13 beta dvd

How reproducible:

I'm pretty sure I remember this happening when I installed f13 alpha, but
I guess I didn't submit a but then.

Steps to Reproduce:
1. I did a hard disk install, booting the isolinux files by making
   a grub.conf entry like so:
title Install Fedora 13 Alpha x86_64
	root (hd0,8)
	kernel /boot/f13x/vmlinuz asknetwork repo=hd:LABEL=ZOOTY:/salvage/iso-images/Fedora-13-Beta-x86_64-DVD/
	initrd /boot/f13x/initrd.img
2. Select lots of packages to custom install, including bind
3. Watch installer hag when it gets to bind
  
Actual results:
see above

Expected results:
installer keeps making progress

Additional info:

I mentioned this in test list for alpha, but I guess didn't file a bug

http://lists.fedoraproject.org/pipermail/test/2010-March/089223.html
Comment 1 Adam Tkac 2010-04-14 08:27:26 EDT
That's odd. Would it be possible to try to install same packages as before without the bind package, please? Does installation hangs as well?
Comment 2 Tom Horsley 2010-04-14 18:53:42 EDT
With the DNS Server package group unchecked (as near as I can tell, that's
only bind and bind-chroot being excluded), the same f13 installation on
a different partition of the same machine does not hang at any point, so
it appears to be something about the bind package itself that causes
the hang.

On the other hand, the funny progress_gui.py error still shows up in the
log, so that is apparently irrelevant.
Comment 3 Tom Horsley 2010-04-14 20:05:08 EDT
I was gonna put a clock on it and see how long it took, so I installed
again, and this time, it only took about 50 seconds. I guess that means
the time delay is random :-(.

Of course even 50 seconds seems like a really long time when most
comparable size packages zip past as fast as you can read the lines.
Comment 4 Adam Tkac 2010-06-28 08:12:21 EDT
In my opinion this issue is caused by "rndc-confgen" call in the %post script in the bind package. rndc-confgen utility generates /etc/rndc.key file and it needs entropy from /dev/random. If there is not enough entropy then it looks like it hangs.

Since this issue is present only on your system I would prefer to close this bug as "notabug". If you think this issue should be fixed somehow then please reopen this ticket. I can consider to move the rndc-confgen call from the %post script to initscript and initscript will write warning that "rndc-confgen" call can take some time.

Closing as notabug, as I wrote above.
Comment 5 Tom Horsley 2010-06-28 08:54:11 EDT
That makes sense, and would explain why it always finished when I started
poking around on the system to find out why it was hung - I was generating
entropy :-).

Note You need to log in before you can comment on or make changes to this bug.