Bug 58210 - Please use correct version label
Please use correct version label
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 20:24 EST by Enrico Scholz
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 04:04:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-01-10 20:24:14 EST
Description of Problem:

autoconf-2.52-5 contains autoconf-2.52f in reality; old ...-2.52-4 was -2.52d.
This relabeling is very confusing...

I don't see a reason why this packages can not be named as 'autoconf-2.52f-1' or
so. RPM works fine and can distinguish between this versions correctly:

----
$ python
>>> import rpm
>>> rpm.labelCompare(['0','2.52','1'], ['0','2.52d','1'])
-1
>>> rpm.labelCompare(['0','2.52d','1'], ['0','2.52','1'])
1
>>> rpm.labelCompare(['0','2.52d','1'], ['0','2.52f','1'])
-1
>>> rpm.labelCompare(['0','2.52f','1'], ['0','2.52d','1'])
1
----

Therefore, rpm would see the packages in order of

| autoconf-2.52-1 < autoconf-2.52d-1 < autoconf-2.52f-1

and upgrading will work without '--force' or so.
Comment 1 Jens Petersen 2002-02-01 03:25:00 EST
autoconf-2.52g-1 fixes this.
Comment 2 Jens Petersen 2002-02-01 04:04:07 EST
oops, forgot that autoconf-2.52g requires automake-1.5b.
This will have to wait a little more. :(
Comment 3 Jens Petersen 2002-02-03 23:55:14 EST
really fixed in 2.52-7 (reverted to 2.52 release).

Note You need to log in before you can comment on or make changes to this bug.