Bug 582111 - "Migration failed" error during live migration
"Migration failed" error during live migration
Status: CLOSED DUPLICATE of bug 499750
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-14 02:59 EDT by Lijian Xu
Modified: 2010-05-26 16:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 16:42:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijian Xu 2010-04-14 02:59:04 EDT
Description of problem:
I'm testing Live Migration feature of libvirt, and when I run the migration command, "migration failed" error occurs.(The same when I remove "--live")

Version-Release number of selected component (if applicable):
    * kernel-2.6.33.1-19.fc13
    * libvirt-0.7.7-1.fc13
    * python-virtinst-0.500.2-3.fc13
    * qemu-0.12.3-6.fc13
    * seabios-0.5.1-1.fc13
    * virt-manager-0.8.3-2.fc13 

How reproducible:
    Unknown.

Steps to Reproduce:
1.Stop firewall and selinux on both source and dest machine.
2.Start the guest machine on source.
3.Run "virsh migrate --live fedora qemu+ssh://10.66.65.51/system"
  
Actual results:
    error: operation failed: migration to 'tcp:live.localdomain:49167' failed: migration failed

    "libvirt -v" on source machine:
14:44:23.080: error : qemuMonitorTextMigrate:1126 : operation failed: migration to 'tcp:live.localdomain:49167' failed: migration failed
libvir: QEMU error : operation failed: migration to 'tcp:live.localdomain:49167' failed: migration failed

    "libvirt -v" on dest machine:
libvir: error : Unknown failure

Additional info:
    I changed /etc/hosts on dest machine like this, because of an "internal error canonical hostname pointed to localhost, but this is not allowed" error:

[root@localhost ~]# cat /etc/hosts
10.66.65.51		live.localdomain	live
::1	localhost.localdomain	localhost6
Comment 1 Cole Robinson 2010-05-26 16:42:30 EDT
If you alter /etc/hosts and want migration to work, the hostname you add needs to resolve from other machines, which live.localdomain probably does not.

Closing as a dup of, which is tracking migration error reporting issues.

*** This bug has been marked as a duplicate of bug 499750 ***

Note You need to log in before you can comment on or make changes to this bug.