Bug 582131 - unsatisfied dependencies after RHEL55@Everything is installed [NEEDINFO]
unsatisfied dependencies after RHEL55@Everything is installed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Ondrej Hudlicky
:
Depends On:
Blocks: 581474
  Show dependency treegraph
 
Reported: 2010-04-14 04:10 EDT by Petr Sklenar
Modified: 2014-06-03 08:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:23:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (psklenar)


Attachments (Terms of Use)
Kickstart what I used for installation (10.96 KB, text/plain)
2010-04-14 04:14 EDT, Petr Sklenar
no flags Details
the whole output from rpm -Va (65.47 KB, text/plain)
2010-04-14 04:19 EDT, Petr Sklenar
no flags Details

  None (edit)
Description Petr Sklenar 2010-04-14 04:10:02 EDT
Description of problem:
There are many unsatisfied dependencies after RHEL55@Everything is installed.

Version-Release number of selected component (if applicable):
redhat-release-5Server-5.5.0.2, kernel booted 2.6.18-194.el5, 2330 packages installed

How reproducible:
always

Steps to Reproduce:
1. install distro with @Everything -@Conflicts
I tried only ia64 but I guess its for all arch
2. see output of rpm -Va
  
Actual results:
unsatisfied dependencies for packages samba and postrge 
^ There are packages mainly from "-@Conflicts group"

Expected results:
NO error like unsatisfied dependencies

Additional info:
snip from logs:
[root@hp-rx2660-03 ~]# rpm -V tdb-tools
Unsatisfied dependencies for tdb-tools-1.1.2-51.el5.ia64: samba-common < 0:3.1, samba
S.5.....  d /usr/share/man/man8/tdbbackup.8.gz
S.5.....  d /usr/share/man/man8/tdbdump.8.gz
S.5.....  d /usr/share/man/man8/tdbtool.8.gz
[root@hp-rx2660-03 ~]# rpm -q samba-common samba
samba-common-3.0.33-3.28.el5
samba-3.0.33-3.28.el5
[root@hp-rx2660-03 ~]# rpm -V samba-common samba
Unsatisfied dependencies for tdb-tools-1.1.2-51.el5.ia64: samba-common < 0:3.1, samba-common < 0:3.1, samba-common < 0:3.1, samba-common < 0:3.1
S.5.....    /etc/rc.d/init.d/winbind
S.5.....  c /etc/samba/smb.conf
S.5.....  d /usr/share/man/man1/ntlm_auth.1.gz
S.5.....  d /usr/share/man/man1/profiles.1.gz
S.5.....  d /usr/share/man/man1/smbcquotas.1.gz
S.5.....  d /usr/share/man/man1/testparm.1.gz
S.5.....  d /usr/share/man/man1/wbinfo.1.gz
S.5.....  d /usr/share/man/man5/lmhosts.5.gz
S.5.....  d /usr/share/man/man5/smb.conf.5.gz
S.5.....  d /usr/share/man/man8/eventlogadm.8.gz
S.5.....  d /usr/share/man/man8/idmap_ad.8.gz
S.5.....  d /usr/share/man/man8/idmap_ldap.8.gz
S.5.....  d /usr/share/man/man8/idmap_nss.8.gz
S.5.....  d /usr/share/man/man8/idmap_rid.8.gz
S.5.....  d /usr/share/man/man8/idmap_tdb.8.gz
S.5.....  d /usr/share/man/man8/net.8.gz
S.5.....  d /usr/share/man/man8/smbpasswd.8.gz
S.5.....  d /usr/share/man/man8/winbindd.8.gz
......G.    /var/cache/samba/winbindd_privileged
Unsatisfied dependencies for tdb-tools-1.1.2-51.el5.ia64: samba, samba, samba, samba, samba
S.5.....  c /etc/logrotate.d/samba
S.5.....  c /etc/rc.d/init.d/smb
S.5.....  d /usr/share/man/man1/smbcontrol.1.gz
S.5.....  d /usr/share/man/man1/smbstatus.1.gz
S.5.....  d /usr/share/man/man5/smbpasswd.5.gz
S.5.....  d /usr/share/man/man7/samba.7.gz
S.5.....  d /usr/share/man/man8/nmbd.8.gz
S.5.....  d /usr/share/man/man8/pdbedit.8.gz
S.5.....  d /usr/share/man/man8/smbd.8.gz
S.5.....  d /usr/share/man/man8/vfs_audit.8.gz
S.5.....  d /usr/share/man/man8/vfs_cacheprime.8.gz
S.5.....  d /usr/share/man/man8/vfs_cap.8.gz
S.5.....  d /usr/share/man/man8/vfs_catia.8.gz
S.5.....  d /usr/share/man/man8/vfs_commit.8.gz
S.5.....  d /usr/share/man/man8/vfs_default_quota.8.gz
S.5.....  d /usr/share/man/man8/vfs_extd_audit.8.gz
S.5.....  d /usr/share/man/man8/vfs_fake_perms.8.gz
S.5.....  d /usr/share/man/man8/vfs_full_audit.8.gz
S.5.....  d /usr/share/man/man8/vfs_gpfs.8.gz
S.5.....  d /usr/share/man/man8/vfs_netatalk.8.gz
S.5.....  d /usr/share/man/man8/vfs_notify_fam.8.gz
S.5.....  d /usr/share/man/man8/vfs_prealloc.8.gz
S.5.....  d /usr/share/man/man8/vfs_readahead.8.gz
S.5.....  d /usr/share/man/man8/vfs_readonly.8.gz
S.5.....  d /usr/share/man/man8/vfs_recycle.8.gz
S.5.....  d /usr/share/man/man8/vfs_shadow_copy.8.gz
S.5.....  d /usr/share/man/man8/vfs_xattr_tdb.8.gz
Comment 1 Petr Sklenar 2010-04-14 04:14:03 EDT
Created attachment 406429 [details]
Kickstart what I used for installation

Machines was installed from satellite which had synced channels with fresh rhel55 content (from rhn.webqa)
Comment 2 Petr Sklenar 2010-04-14 04:19:01 EDT
Created attachment 406430 [details]
the whole output from rpm -Va

attached the whole output from rpm -Va after system was installed.

# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
No problems found

[root@hp-rx2660-03 ~]# rpm -qa | wc -l
2331

[root@hp-rx2660-03 ~]# uname -a
Linux hp-rx2660-03.rhts.eng.bos.redhat.com 2.6.18-194.el5xen #1 SMP Tue Mar 16 22:16:55 EDT 2010 ia64 ia64 ia64 GNU/Linux

[root@hp-rx2660-03 ~]# rpm -q redhat-release
redhat-release-5Server-5.5.0.2
Comment 3 Petr Sklenar 2010-04-14 04:23:35 EDT
Issue is in wrong version of packages, for ex tdb-tools needs newer version of samba-common:

[root@hp-rx2660-03 ~]# rpm -V tdb-tools
Unsatisfied dependencies for tdb-tools-1.1.2-51.el5.ia64: samba-common < 0:3.1, samba
S.5.....  d /usr/share/man/man8/tdbbackup.8.gz
S.5.....  d /usr/share/man/man8/tdbdump.8.gz
S.5.....  d /usr/share/man/man8/tdbtool.8.gz

[root@hp-rx2660-03 ~]# rpm -q samba-common
samba-common-3.0.33-3.28.el5
Comment 4 Petr Sklenar 2010-04-14 04:45:24 EDT
There are <packagereq type="mandatory">tdb-tools</packagereq> in @conflicts group (comps file). But this packages is installed.
Comment 10 RHEL Product and Program Management 2010-08-09 15:28:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2014-03-07 08:57:23 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 12 RHEL Product and Program Management 2014-06-03 08:23:29 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.