Bug 58219 - Installer Crashes in 7.1 -> 7.2 Upgrade
Installer Crashes in 7.1 -> 7.2 Upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 22:23 EST by ensafi
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 22:24:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (70.41 KB, text/plain)
2002-01-10 22:24 EST, ensafi
no flags Details

  None (edit)
Description ensafi 2002-01-10 22:23:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; Q312461; (R1 
1.1))

Description of problem:
The anaconda installer crashed with an exception when it was nearly 80% done 
with an upgrade from Red Hat Linux 7.1 to 7.2. The generated log file has been 
attached. Early during the upgrade, the installer reported that the RPM for 
time-1.7 was not found on the media. I was using an original retail Red Hat CD-
ROM. I hit the <Esc> key to allow the installer to continue without upgrading 
time-1.7, and the upgrade continued without any problems until it crashed.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
Simply try to upgrade from 7.1 to 7.2 using original retail Red Hat Linux 7.2 
CD-ROM. In chose to: (1) upgrade, (2) change from LILO to GRUB, and (3) did not 
customize packages to be upgraded.

Actual Results:  The RPM for time-1.7 was not found, but it did exist on the CD-
ROM. The installer proceeded past this problem, and much later on, it 
encountered a fatal exception and crashed. The system was only partially 
upgraded, and the boot sector still contained LILO instead of GRUB, but LILO no 
longer worked and displayed "LI". I was able to boot using a boot floppy, but 
many services failed at startup.

Expected Results:  A smooth upgrade from 7.1 to 7.2 with GRUB replacing LILO.

Additional info:
Comment 1 ensafi 2002-01-10 22:24:25 EST
Created attachment 42271 [details]
anaconda dump
Comment 2 Jeremy Katz 2002-01-15 14:26:31 EST
There was an error reading the CD, likely due to a bad CD.  If this is a
downloaded image, please verify the md5sum versus those published on our web
site.  If you have purchased an official copy of Red Hat Linux, please contact
support.

Note You need to log in before you can comment on or make changes to this bug.