Bug 582217 - @everything install fails if "-@conflicts" is not the last line in %packages section
@everything install fails if "-@conflicts" is not the last line in %packages ...
Status: CLOSED DUPLICATE of bug 577334
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks: 581474
  Show dependency treegraph
 
Reported: 2010-04-14 08:26 EDT by Jan Stodola
Modified: 2010-11-09 08:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-14 10:03:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2010-04-14 08:26:59 EDT
Description of problem:
Kickstart installation of everything package set fails if any package is specified after line with "-@conflicts". Installation fails because of file conflicts.

For example, this one fails:
%packages
*
-@conflicts
kernel

This is working:
%packages
*
kernel
-@conflicts

tail -n 20 /tmp/anaconda.log
11:57:51 DEBUG   : Member: java-1.6.0-openjdk-src.x86_64 1-1.6.0.0-1.7.b09.el5 - u
11:57:51 DEBUG   : Adding Package 1:java-1.6.0-openjdk-src-1.6.0.0-1.7.b09.el5.x86_64 in mode u
11:58:16 ERROR   : file conflicts: file /usr/bin/ecpg conflicts between attempted installs of postgresql84-devel-8.4.2-5.el5.i386 and postgresql-devel-8.1.18-2.el5_4.1.i386
11:58:16 ERROR   : error running transaction: file /usr/bin/ecpg conflicts between attempted installs of postgresql84-devel-8.4.2-5.el5.i386 and postgresql-devel-8.1.18-2.el5_4.1.i386
11:58:16 ERROR   : file conflicts: file /usr/bin/pg_config conflicts between attempted installs of postgresql84-devel-8.4.2-5.el5.i386 and postgresql-devel-8.1.18-2.el5_4.1.i386
11:58:16 ERROR   : error running transaction: file /usr/bin/pg_config conflicts between attempted installs of postgresql84-devel-8.4.2-5.el5.i386 and postgresql-devel-8.1.18-2.el5_4.1.i386
11:58:16 ERROR   : file conflicts: file /lib/libnss_winbind.so.2 conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : error running transaction: file /lib/libnss_winbind.so.2 conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : file conflicts: file /lib/security/pam_winbind.so conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : error running transaction: file /lib/security/pam_winbind.so conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : file conflicts: file /usr/bin/ntlm_auth conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : error running transaction: file /usr/bin/ntlm_auth conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : file conflicts: file /usr/bin/wbinfo conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : error running transaction: file /usr/bin/wbinfo conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : file conflicts: file /usr/lib/samba/idmap/ad.so conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : error running transaction: file /usr/lib/samba/idmap/ad.so conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : file conflicts: file /usr/lib/samba/idmap/rid.so conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : error running transaction: file /usr/lib/samba/idmap/rid.so conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : file conflicts: file /usr/sbin/winbindd conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386
11:58:16 ERROR   : error running transaction: file /usr/sbin/winbindd conflicts between attempted installs of samba-common-3.0.33-3.28.el5.i386 and samba3x-winbind-3.3.8-0.51.el5.i386


Version-Release number of selected component (if applicable):
RHEL 5.5, tested with x86_64 arch

How reproducible:
always

Steps to Reproduce:
1. start kickstart installation with %package section:
%packages
*
-@conflicts
kernel

Actual results:
Anaconda fails because of file conflicts.

Expected results:
Anaconda installs all packages without error.
Comment 2 Alexander Todorov 2010-04-14 08:53:18 EDT
Jan,
was this test with a satellite server or plain http/nfs/ftp repository? Does the comps.xml in the repository contain the conflicts group?
Comment 4 Alexander Todorov 2010-04-14 09:44:04 EDT
It looks like bug #577334 may turn to be a duplicate of this one after all. The ks.cfg used there also specified additional packages after the -@conflicts line.
Comment 5 Chris Lumens 2010-04-14 10:03:20 EDT

*** This bug has been marked as a duplicate of bug 577334 ***

Note You need to log in before you can comment on or make changes to this bug.