This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 582356 - libvirt: Volume allocation is painfully slow on non ext4
libvirt: Volume allocation is painfully slow on non ext4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 584320 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-14 13:51 EDT by Cole Robinson
Modified: 2012-11-01 10:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: libvirt-0.7.7-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 19:37:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2010-04-14 13:51:19 EDT
As title says, volume allocation is painfully slow in non ext4 filesystems, less than a MB/sec isn't cool when allocating 8gb by default (as virt-manager does).

Fixed upstream here, worth getting in for F13 GA:

http://libvirt.org/git/?p=libvirt.git;a=commit;h=e3c36a2575bc88a16d776693dc39ea01c780b406
Comment 1 Fedora Update System 2010-04-20 15:56:20 EDT
libvirt-0.7.7-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libvirt-0.7.7-3.fc13
Comment 2 Cole Robinson 2010-04-21 09:40:59 EDT
*** Bug 584320 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-04-21 17:52:29 EDT
libvirt-0.7.7-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libvirt-0.7.7-3.fc13
Comment 4 Fedora Update System 2010-04-30 19:37:49 EDT
libvirt-0.7.7-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 defa 2012-11-01 10:44:16 EDT
I am not quite sure whether it's the same bug, but the effects seem to be the same. I run libvirt 0.8.3 on Debian Squezze. I have an LVM volume group used by libvirt - all volumes are ext4 and the volumes group is crypted with LUKS. Using vol-clone or the virt-clone tools also results in cloning speed of approx. 1MB/s. When I do the same using dd i achieve approx. 25MB/s which shows there is a bottleneck somewhere. Help would be apprecheated.
Comment 6 Cole Robinson 2012-11-01 10:46:00 EDT
(In reply to comment #5)
> I am not quite sure whether it's the same bug, but the effects seem to be
> the same. I run libvirt 0.8.3 on Debian Squezze. I have an LVM volume group
> used by libvirt - all volumes are ext4 and the volumes group is crypted with
> LUKS. Using vol-clone or the virt-clone tools also results in cloning speed
> of approx. 1MB/s. When I do the same using dd i achieve approx. 25MB/s which
> shows there is a bottleneck somewhere. Help would be apprecheated.

Please file a bug with your distro, and provide a link to the patch mentioned in Comment #0

Note You need to log in before you can comment on or make changes to this bug.