Bug 58246 - keyboard and mouse hang at boot following install of 7.2
keyboard and mouse hang at boot following install of 7.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-11 13:19 EST by Need Real Name
Modified: 2014-03-16 22:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 17:48:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-11 13:19:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I have installed RedHat Linux 7.2 as provided with the "RedHat Linux 7.2 BIBLE" 
book. The mouse and keyword work fine throughout the installation process. At 
the end of this process when the system starts its boot into Linux (gui mode), 
I am presented with the gui login screen but the mouse and keyboard are both 
dead. Neither num-lock or caps-lock toggle the led.

I have tried this several times and these symptoms are consistent. I.e., mouse 
and keyboard work fine during install but hang on boot.

I am using a Gateway 2000 computer and keyboard. The mouse is Microsoft version 
2.1a. "Neither" are usb. 

The Gateway board is: GM430TX 4000205 QGTY4000205-D1
BIOS: American Megatrends, Inc  0AAES035 07/15/95

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot: linux text
2./usr/sbin/kudzu
3.keyboard hangs

Once in the 'text' mode keyboard works find until the 'kudzu' is invoked. Power 
to the keyboard is not actually lost, just hung. For example, enter 
the /usr/sbin/kudzu commmand but just prior to pressing return set the caps 
lock on. Hit return. At some point the keyword will freeze but the caps led 
will still be lit.	 Unable to test the 'mouse' in text mode.



Actual Results:  keyboard repeatedly hangs. 

Additional info:

This relates to bugs: 55096, 55678 and 55878 with regard to the keyword. 
Although, my keyboard is NOT usb. I did not find any related bugs for the mouse 
hang.



Note:   200 mHz Pentium; not sure what x86
Comment 1 Peter van Egdom 2002-12-26 05:30:10 EST
I've encountered this bug for the first time on my Pentium IV desktop system with 
Red Hat Linux release 8.0.92 (Phoebe). The problem as described by the reporter
of this
bug is exactly the same as what I'm experiencing now myself.

With Red Hat Linux 8.0 I had no problems on this same system.

I did a fresh install of Phoebe. All CD's are 100% CRC checked.

When Phoebe boots on my system my keyboard works until kudzu does a hardware
probe. When the system had started X and gdm, I cannot log in. I had to press
the power-off button to fix this problem by starting in a different runlevel.

By starting the system in runlevel 2 (not 3) I could disable kudzu with the command
"chkconfig --level 0123456 kudzu off".

When I had done this I can start Phoebe in runlevel 5 again.

My keyboard is a PS/2 type and my mouse a USB type.

I'll be happy to provided more information if needed.
Comment 2 Peter van Egdom 2003-02-27 18:26:35 EST
Just for info, this bug seems fixed on my system described above with Phoebe 8.0.94.
Comment 3 Need Real Name 2003-08-12 17:56:18 EDT
I have just tried to instal version 7.2 on my computer P2 -Celeron 366, (can 
give motherboard details if required) and exactly the same problem as 
originally described occurs
Comment 4 Bill Nottingham 2005-02-04 17:48:50 EST
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please attempt to confirm with more recent releases.

Note You need to log in before you can comment on or make changes to this bug.