Bug 582468 - X server uses the wrong configuration directory
Summary: X server uses the wrong configuration directory
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-15 04:22 UTC by Peter Hutterer
Modified: 2010-05-04 05:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-04 05:54:36 UTC


Attachments (Terms of Use)

Description Peter Hutterer 2010-04-15 04:22:34 UTC
Description of problem:
Fedora was the first distro to ship the xorg.conf.d (I think). We've chosen /etc/xorg.conf.d as configuration directory.

In the upstream 1.8.0 release, the decision fell onto /etc/X11/xorg.conf.d instead. Queued patches for the 1.8.1 release change the behaviour to use /usr/share/X11/xorg.conf.d for distribution-provided config files and /etc/X11/xorg.conf.d for the user's configurations.

To match upstream, this needs to be changed in rawhide and F-13. Staying with /etc/xorg.conf.d would mean carrying patches for the forseeable future to avoid regressions in user setups. Rectifying this before the release comes out is rather vital.


Affected packages:
xorg-x11-server
system-setup-keyboard
xorg-x11-drv-wacom
xorg-x11-drv-synaptics
xorg-x11-drv-fpit
xorg-x11-drv-vmmouse

Comment 1 Fedora Update System 2010-04-15 05:59:34 UTC
system-setup-keyboard-0.8.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-setup-keyboard-0.8.5-1.fc13

Comment 2 Fedora Update System 2010-04-15 06:21:23 UTC
xorg-x11-server-1.8.0-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.8.0-6.fc13

Comment 3 Fedora Update System 2010-04-15 06:23:06 UTC
xorg-x11-drv-fpit-1.3.0-10.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-drv-fpit-1.3.0-10.fc13

Comment 4 Fedora Update System 2010-04-15 06:23:38 UTC
xorg-x11-drv-wacom-0.10.5-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-drv-wacom-0.10.5-2.fc13

Comment 5 Fedora Update System 2010-04-15 06:24:02 UTC
xorg-x11-drv-vmmouse-12.6.9-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-drv-vmmouse-12.6.9-2.fc13

Comment 6 Fedora Update System 2010-04-15 06:24:06 UTC
xorg-x11-drv-synaptics-1.2.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.2.2-3.fc13

Comment 7 Fedora Update System 2010-04-21 02:21:20 UTC
xorg-x11-server-1.8.0-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Peter Hutterer 2010-04-21 05:45:27 UTC
Great, mixed up F13Target and F13Blocker when filing. This is definitely a blocker.

Comment 9 Peter Hutterer 2010-04-21 05:49:37 UTC
All packages have the karma required (except fpit but I doubt anyone would even notice if we deleted it). Can someone please approve these packages for critpath updates. 

Right now only the server was pushed into stable, which means that input devices except mouse and keyboard _will_ break in the current package set.

Comment 10 Fedora Update System 2010-04-21 21:55:54 UTC
xorg-x11-drv-synaptics-1.2.2-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-04-22 22:42:30 UTC
system-setup-keyboard-0.8.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Adam Williamson 2010-04-23 20:00:24 UTC
Discussed at today's blocker review meeting. We agreed this is a blocker. We've added Bodhi feedback to un-stick the two updates that need it (vmmouse and wacom). Not sure what to do with fpit, maybe just push it through since it's unlikely you screwed up that change and got all the others right?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Fedora Update System 2010-04-25 13:47:41 UTC
xorg-x11-drv-vmmouse-12.6.9-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-04-25 14:01:53 UTC
xorg-x11-drv-wacom-0.10.5-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Peter Hutterer 2010-04-27 06:15:12 UTC
(In reply to comment #12)
> Discussed at today's blocker review meeting. We agreed this is a blocker. We've
> added Bodhi feedback to un-stick the two updates that need it (vmmouse and
> wacom). 

Thanks!

> Not sure what to do with fpit, maybe just push it through since it's
> unlikely you screwed up that change and got all the others right?

tbh, I don't think anyone would really notice if it breaks for quite a while. So I'd even be fine with leaving it out and making it available as an update later onwards.

Comment 16 Adam Williamson 2010-04-29 15:15:09 UTC
Doesn't feel very neat...I think I'll just blind +1 it, I promise to take the consequences if it somehow eats everyone's babies =)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 17 Adam Williamson 2010-04-30 20:05:32 UTC
as the important updates have all been pushed, dropping this from blocker list. it can be closed as soon as someone pushes the fpit update (it has the necessary karma now).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 18 Fedora Update System 2010-04-30 23:50:10 UTC
xorg-x11-drv-fpit-1.3.0-10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Peter Hutterer 2010-05-04 05:54:36 UTC
Closing as fixed now that fpit is in stable too.


Note You need to log in before you can comment on or make changes to this bug.