Bug 582507 - virt-install fails to register storage with virt-manager
virt-install fails to register storage with virt-manager
Status: CLOSED DUPLICATE of bug 557107
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 03:59 EDT by Jes Sorensen
Modified: 2014-07-06 15:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 17:28:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2010-04-15 03:59:27 EDT
Description of problem:
When installing a guest using virt-install, the storage used for the guest, is not registered so that virt-manager knows about it.

Ie. after the install, when looking at it with virt-manager, it doesn't show up anywhere under managed storage, as it would do if one uses virt-manager to install the image.

Version-Release number of selected component (if applicable):
python-virtinst-0.500.0-1.el6.2.noarch
virt-manager-0.8.0-2.el6.1.noarch

How reproducible:


Steps to Reproduce:
1. Take a fresh install of RHEL60A3
2. Run virt-install --prompt and go through the process.
3. Launch virt-manager, right click on host->Details->Storage
  
Actual results:
Nothing is listed under managed storage

Expected results:
The image or the image directory should be listed.

Additional info:
I am now sure if this is a virt-install or virt-manager bug, so feel free to move it appropriately.
Comment 2 RHEL Product and Program Management 2010-04-15 05:14:05 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Cole Robinson 2010-05-04 10:55:27 EDT
If the user points to a directory that isn't a libvirt storage pool, we don't auto-poolify it (teach libvirt/virt-manager about it), we just provision one off storage on move along. I'm starting to think this isn't the way to do things though. Either way this is RHEL6.1 material since it would be a ripe for regressions.
Comment 5 Suzanne Yeghiayan 2011-03-28 17:08:02 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.
Comment 7 Cole Robinson 2011-09-27 11:06:45 EDT
Isn't looking likely for 6.2, moving to 6.3
Comment 9 Cole Robinson 2011-12-09 18:34:28 EST
Fixing this is an important long term improvement for virtinst/virt-manager, but it will be invasive. And given that our capacity for virt-manager work is reduced for RHEL, I'm moving this to the upstream tracker.
Comment 10 Cole Robinson 2012-02-07 17:28:53 EST
Duping to virt-manager bug for autopoolifying storage, since it's all going to be the same fix.

*** This bug has been marked as a duplicate of bug 557107 ***

Note You need to log in before you can comment on or make changes to this bug.