Bug 582510 - KS config page should offer only available channels/repos
KS config page should offer only available channels/repos
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Martin Minar
:
Depends On:
Blocks: 581474 sat560-lowbug
  Show dependency treegraph
 
Reported: 2010-04-15 04:12 EDT by Jan Hutař
Modified: 2016-07-03 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rdate package was requested from Workstation repo/channel (8.78 KB, text/plain)
2010-04-15 04:12 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2010-04-15 04:12:50 EDT
Created attachment 406703 [details]
rdate package was requested from Workstation repo/channel

Description of problem:
When I'm creating KS, I'm presented with the possibility to enable install-time repositories for which I do not have channel synced.


Version-Release number of selected component (if applicable):
5.3.0


How reproducible:
always


Steps to Reproduce:
1. see Kickstart Details -> Operating System -> Repositories:


Actual results:
I'm able to check repository for which I do not have channel synced and generated kickstart contains:

repo --name=<repo> --baseurl=http://smqa-r210-03.lab.eng.brq.redhat.com/ks/dist/ks-rhel-i386-client-5-u5/<repo>


Expected results:
E.g. I should not be able to check Workstation repository if I do not have workstation child channel synced.


Additional info:
When I have enabled Workstation repo (not having relevant channel synced) and then provisioned RHEL5-U5 Client XEN PV guest, installation failed on the attempt to install first package. Please see attachment.
Comment 1 Tomas Lestach 2013-05-21 07:44:32 EDT
repos checkboxes without available repodata will be disabled ...

spacewalk.git: 22f7bef174035bb86f89bbd34f51c8a95984aa84
Comment 3 Clifford Perry 2013-10-01 17:52:25 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.