Bug 58265 - fhs "compliance" on openssl
fhs "compliance" on openssl
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openssl (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-12 10:09 EST by Seth Vidal
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 23:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2002-01-12 10:09:26 EST
the openssl pkg puts its certs directory in /usr/share/ssl/certs

If an admin is putting certs in place they would then have to place or symlink
them into /usr/share/ssl/certs

Since an ssl key is more like a config file it should probably be in
/etc/ssl/certs. Additionally it makes backups more simple b/c you can just grab
/etc and get all the critical files in one place.

It doesn't make sense for a directory where a user should put files for the
system to be in /usr which could be mounted ro.

Thanks
Comment 1 Seth Vidal 2004-05-04 23:26:14 EDT
not gonna happen too much stuff would break on upgrade

Note You need to log in before you can comment on or make changes to this bug.