Bug 582680 - <indexterm> should be standalone in a translation
<indexterm> should be standalone in a translation
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 10:50 EDT by Raphaël Hertzog
Modified: 2010-11-23 23:16 EST (History)
6 users (show)

See Also:
Fixed In Version: publican-1.6.3-0.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 14:57:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jfearn: needinfo-
jfearn: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Raphaël Hertzog 2010-04-15 10:50:59 EDT
Description of problem:

If you have
<indexterm><primary>package</primary><secondary>search</secondary></indexterm> outside of a translatable tag, in the PO file you will have to translate "package" and "search" separately.

This is too fine-grained and will not allow proper translation in many cases
(consider when "search" is meant as a noun and when "search" is meant as verb, it will often require two different words in other languages).

In the same spirit, a translator might want to create two entries in the index for a given expression because there's no clear mapping for the given expression. If the PO file contains only the content of <indexterm> and not the tag in its entirety, he will not be able to do this.
Comment 1 Jeff Fearn 2010-05-04 00:08:33 EDT
Made indexterm a single translation entry.
Comment 2 Ruediger Landmann 2010-05-06 01:05:24 EDT
<indexterm><primary>package</primary><secondary>search</secondary></indexterm> 

appears as two separate msgids in version 1.6.3.t122:

#. Tag: primary
#, no-c-format
msgid "package"
msgstr ""

#. Tag: secondary
#, no-c-format
msgid "search"
msgstr ""
Comment 3 Ruediger Landmann 2010-05-06 01:42:10 EDT
Confirmed fixed in version 1.6.3.t150
Comment 4 jito 2010-05-11 18:46:44 EDT
<indexterm> tags do not appear on the test PO file; <primary> and <secondary> tags are now separate entries.
Comment 5 jito 2010-05-11 23:51:45 EDT
Further to the comment above, there are entries in the PO files that correspond to <indexterm> tags even though these tags do not appear on the files:

#. Tag: indexterm
#, no-c-format
msgid "<primary>text elements</primary><secondary>basic</secondary>"
msgstr ""
Comment 6 Fedora Update System 2010-05-13 18:20:58 EDT
publican-1.6.3-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc13
Comment 7 Fedora Update System 2010-05-13 18:22:14 EDT
publican-1.6.3-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc12
Comment 8 Fedora Update System 2010-05-15 16:36:38 EDT
publican-1.6.3-0.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc12
Comment 9 Fedora Update System 2010-05-15 16:45:51 EDT
publican-1.6.3-0.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-1.6.3-0.fc13
Comment 10 Fedora Update System 2010-05-17 14:55:55 EDT
publican-1.6.3-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-05-17 14:59:46 EDT
publican-1.6.3-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.