Bug 58273 - Some init scripts use /bin/bash - unneccessary?
Summary: Some init scripts use /bin/bash - unneccessary?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: SysVinit   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-12 16:15 UTC by Harri Haataja
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-14 05:27:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Harri Haataja 2002-01-12 16:15:50 UTC
Description of Problem:
Some init scripts use #!/bin/bash while many others similiar work with /bin/sh.
This makes a less abstract dependency to bash. I'm not sure if there's bashisms
there somewhere but it would be nice to have a simpler net of dependencies and
more cinsistency.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Bill Nottingham 2002-01-14 05:27:24 UTC
This is because the $"..." localization method requires bash.


Note You need to log in before you can comment on or make changes to this bug.