Bug 58274 - pcmcia network cards not listed
pcmcia network cards not listed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-12 11:33 EST by Garrett Mitchener
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 11:13:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Garrett Mitchener 2002-01-12 11:33:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011014

Description of problem:
I have a notebook computer and a Xircom pcmcia network card, which works with
the xircom_tulip_cb.o kernel module.  However, that module and as far as I can
tell no other pcmcia modules are not listed in the Adapter drop list.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Click "Add"
2. Click "Ok" to add an ethernet connection
3. Look in the Adapter drop list, no Xircom driver.
	

Additional info:

I suspect, based on a quick glance through the python code for neat, that the
hardware list comes from /boot/module-info, and for whatever reason, this file
doesn't describe pcmcia devices.  I'm guessing it's generated from kernel source
and someone just forgot to run the generator on the pcmcia drivers directory.

I feel I should add that it took me a *long* time to figure out how to get my
network card running because of this little glitch in your GUI tool.  The help
button was also not very helpful: It called up a web browser which attempted to
pull documentation off the internet, which of course didn't work because my
network card wasn't working at that point. (I believe that bug is already
documented in bugzilla.)
Comment 1 Trond Eivind Glomsrxd 2002-01-14 15:18:48 EST
The help it looks for should be on the system... is the version on
http://people.redhat.com/teg/neat/ any better?
Comment 2 Garrett Mitchener 2002-01-14 16:04:54 EST
I installed the version 0.9.10 RPM in http://people.redhat.com/teg/neat/, and
the help button does call up a file on the local file system, which is good. 
I'm a little confused because the help file is partly about neat and partly
about a druid for making network connections, but it doesn't say how to start
the druid.  Should there be two separate help pages?

This version also doesn't list my network card in the drop list.

Comment 3 Harald Hoyer 2002-04-03 05:46:41 EST
will support it with a newer kernel (kernel-2.4.18-0.13), cause neat directly 
questiones the module and also uses /boot/module-info

Note You need to log in before you can comment on or make changes to this bug.