Bug 582779 - fails for URL installs
fails for URL installs
Status: CLOSED DUPLICATE of bug 566425
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 15:08 EDT by Bill Nottingham
Modified: 2014-03-16 23:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-15 16:04:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-04-15 15:08:09 EDT
Description of problem:

/usr/bin/virt-install -n splat-rhel6 -r 768 --vcpus=1 --os-type=linux --os-variant=rhel6 --disk path=/var/lib/libvirt/images/splat-rhel6.img --network bridge=virbr0 --noreboot -l nfs:curly.devel.redhat.com:/vol/engineering/devarchive/redhat/nightly/RHEL6.0-20100415.n.1/6/Server/x86_64/os/ -d
Thu, 15 Apr 2010 15:06:20 DEBUG    Requesting libvirt URI default
Thu, 15 Apr 2010 15:06:20 DEBUG    Received libvirt URI qemu:///system
Thu, 15 Apr 2010 15:06:20 DEBUG    Requesting virt method 'default', hv type 'default'.
Thu, 15 Apr 2010 15:06:20 DEBUG    Received virt method 'hvm'
Thu, 15 Apr 2010 15:06:20 DEBUG    Hypervisor name is 'kvm'
Thu, 15 Apr 2010 15:06:20 DEBUG    parse_disk: returning {'format': None, 'bus': None, 'readOnly': False, 'volInstall': None, 'path': '/var/lib/libvirt/images/splat-rhel6.img', 'device': 'disk', 'volName': None, 'conn': <libvirt.virConnect instance at 0x27c2518>, 'size': None, 'driverCache': None, 'shareable': False, 'sparse': True}
Thu, 15 Apr 2010 15:06:20 DEBUG    DISPLAY is set: graphics defaulting to VNC.
Thu, 15 Apr 2010 15:06:20 DEBUG    DistroInstaller location is a network source.


Starting install...
Thu, 15 Apr 2010 15:06:21 DEBUG    Preparing mount at /var/lib/libvirt/boot/virtinstmnt.HwC6an
Thu, 15 Apr 2010 15:06:21 DEBUG    Attempting to detect distro:
Thu, 15 Apr 2010 15:06:21 DEBUG    Fetching URI: /var/lib/libvirt/boot/virtinstmnt.HwC6an/.treeinfo
Thu, 15 Apr 2010 15:06:21 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-.treeinfo.s0NgDu
Retrieving file .treeinfo...                             | 3.5 kB     00:00 ... 
Thu, 15 Apr 2010 15:06:21 DEBUG    Fetching URI: /var/lib/libvirt/boot/virtinstmnt.HwC6an/images/pxeboot/vmlinuz
Thu, 15 Apr 2010 15:06:21 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-vmlinuz.gERJfv
Retrieving file vmlinuz...                               | 7.2 MB     00:00 ... 
Thu, 15 Apr 2010 15:06:21 DEBUG    Fetching URI: /var/lib/libvirt/boot/virtinstmnt.HwC6an/images/pxeboot/initrd.img
Thu, 15 Apr 2010 15:06:22 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-initrd.img.bgVR5R
Retrieving file initrd.img...                            |  58 MB     00:01 ... 
Thu, 15 Apr 2010 15:06:22 DEBUG    Cleaning up mount at /var/lib/libvirt/boot/virtinstmnt.HwC6an
Thu, 15 Apr 2010 15:06:22 DEBUG    Creating guest from:
<domain type='kvm'>
  <name>splat-rhel6</name>
  <currentMemory>786432</currentMemory>
  <memory>786432</memory>
  <uuid>d4738aed-da15-65df-d54b-c9a8f4a76211</uuid>
  <os>
    <type arch='x86_64'>hvm</type>
    <kernel>/var/lib/libvirt/boot/virtinst-vmlinuz.gERJfv</kernel>
    <initrd>/var/lib/libvirt/boot/virtinst-initrd.img.bgVR5R</initrd>
    <cmdline>method=nfs:curly.devel.redhat.com:/vol/engineering/devarchive/redhat/nightly/RHEL6.0-20100415.n.1/6/Server/x86_64/os/</cmdline>
  </os>
  <features>
    <acpi/><apic/><pae/>
  </features>
  <clock offset="utc"/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <vcpu>1</vcpu>
  <devices>
    <emulator>/usr/bin/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/var/lib/libvirt/images/splat-rhel6.img'/>
      <target dev='vda' bus='virtio'/>
    </disk>
    <interface type='bridge'>
      <source bridge='virbr0'/>
      <mac address='52:54:00:0f:5d:37'/>
      <model type='virtio'/>
    </interface>
    <input type='tablet' bus='usb'/>
    <graphics type='vnc' port='-1' keymap='en-us'/>
    <console type='pty'/>
  </devices>
</domain>

Thu, 15 Apr 2010 15:06:22 DEBUG    Removing /var/lib/libvirt/boot/virtinst-vmlinuz.gERJfv
Thu, 15 Apr 2010 15:06:22 DEBUG    Removing /var/lib/libvirt/boot/virtinst-initrd.img.bgVR5R
Thu, 15 Apr 2010 15:06:24 ERROR    internal error Process exited while reading console log output: char device redirected to /dev/pts/0
qemu: could not load kernel '/var/lib/libvirt/boot/virtinst-vmlinuz.gERJfv': Permission denied

Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start splat-rhel6'; otherwise, please
 restart your installation.
Thu, 15 Apr 2010 15:06:24 ERROR    internal error Process exited while reading console log output: char device redirected to /dev/pts/0
qemu: could not load kernel '/var/lib/libvirt/boot/virtinst-vmlinuz.gERJfv': Permission denied
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 972, in <module>
    main()
  File "/usr/bin/virt-install", line 834, in main
    start_time, guest.start_install)
  File "/usr/bin/virt-install", line 896, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 798, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 899, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1147, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/0
qemu: could not load kernel '/var/lib/libvirt/boot/virtinst-vmlinuz.gERJfv': Permission denied

Version-Release number of selected component (if applicable):

python-virtinst-0.500.2-3.fc13.noarch
libvirt-0.7.7-1.fc13.x86_64
qemu-kvm-0.12.3-6.fc13.x86_64

How reproducible:

100%
Comment 1 Cole Robinson 2010-04-15 16:04:25 EDT

*** This bug has been marked as a duplicate of bug 566425 ***

Note You need to log in before you can comment on or make changes to this bug.