Bug 58281 - ftp-0.17-12 does not "ls" while connected to wu-ftpd-2.6.1-20
ftp-0.17-12 does not "ls" while connected to wu-ftpd-2.6.1-20
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-12 15:45 EST by arvydas
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:33:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description arvydas 2002-01-12 15:45:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
"ls" command does not return any directory contents while connecting to wu-ftp
(v2.6.1) with the simple ftp client (0.17) but it works when connecting win2000
(sp1) simple client. it used to work before applying the latest wu-ftpd rpm with
rhnetwork-up2date.

www.wu-ftpd.org reports that "starting wu-ftpd version 2.6.0 the interpretation
of NLST versus LIST ftp commands has been changed to what is the right
interpretation". their suggestion is to fix the older clients (i assume ftp-0.17
is one of them).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install the wu-ftpd-2.6.1-20 and client ftp-0.17-12 with default
configuration. up2date says they are the latest on rh-network.
2. ftp the remote(!) wu-ftpd machine (ftp to localhost works) with "ftp" client.
it makes no difference betweem real and anonymous users.
3. "ls". you get: "ftp: connect: Connection refused".

Actual Results:  test@remote /home/test: ftp ftp.server.com
Connected to ftp.server.com (64.152.11.226).
220 master FTP server (Version wu-2.6.1-20) ready.
Name (ftp.server.com:test): anonymous
331 Guest login ok, send your complete e-mail address as password.
Password:
230 Guest login ok, access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls -la
227 Entering Passive Mode (64,152,11,226,45,59)
ftp: connect: Connection refused
ftp>


Expected Results:  
test@remote /home/test: ftp ftp.server.com
Connected to ftp.server.com (64.152.11.226).
220 master FTP server (Version wu-2.6.1-20) ready.
Name (ftp.server.com:test): anonymous
331 Guest login ok, send your complete e-mail address as password.
Password:
230 Guest login ok, access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls -la
200 PORT command successful
150 Opening ASCII mode data connection for directory listing.
total 48
drwxr-xr-x   6 root root 4096 Nov 25 12:57 .
drwxr-xr-x   6 root root 4096 Nov 25 12:57 ..
d--x--x--x   2 root root 4096 Nov 25 12:57 bin
d--x--x--x   2 root root 4096 Dec 24 01:14 etc
drwxr-xr-x   2 root root 4096 Dec 24 01:14 lib
drwxr-xr-x   2 root 50   4096 Nov 25 16:12 pub
226 Transfer complete.
367 bytes received in 0.00 seconds (367000.00 Kbytes/sec)
ftp>


Additional info:

the expected results have been taken from win 2k and win nt 4.0 (sp 5) simple
"ftp" client
Comment 1 Bernhard Rosenkraenzer 2002-01-17 06:56:07 EST
I can't reproduce this. Are you sure your firewall rules are OK? The fact that
it works locally (wu-ftpd doesn't make a difference there) implies something is
wrong with your network setup.
It's definitely not the NLST problem, we fixed the ftp client 2 years back.
Comment 2 Thomas Woerner 2004-08-13 05:33:17 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.