Bug 58282 - run-parts needs a -v to output exactly when a job is running to syslog
run-parts needs a -v to output exactly when a job is running to syslog
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: crontabs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-12 16:20 EST by Seth Vidal
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 00:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
enables -v (verbosity) in run-parts (1.21 KB, patch)
2002-01-12 16:21 EST, Seth Vidal
no flags Details | Diff

  None (edit)
Description Seth Vidal 2002-01-12 16:20:54 EST
run-parts should have a -v so it outputs when a job is being run to syslog via
logger when its going through a dir.

ie: run-parts -v /etc/cron.daily/ would output messages to the logs saying when
it is beginning and ending each individual script inside the cron dir.

it would greatly help debugging problems occuring due to cron jobs.

I will attach a patch to this bug that provides this functionality.

this means crontabs will depend on util-linux (b/c it provides logger) - not a
big deal I think.
Comment 1 Seth Vidal 2002-01-12 16:21:38 EST
Created attachment 42351 [details]
enables -v (verbosity) in run-parts
Comment 2 Eido Inoue 2002-02-12 14:05:09 EST
Thanks for the patch. We'll evaluate and test it and try to get it in the next
release.
Comment 3 Seth Vidal 2005-03-30 00:54:08 EST
wow, closing this.

Note You need to log in before you can comment on or make changes to this bug.