Bug 58285 - ifup should support DHCPINFORM requests
ifup should support DHCPINFORM requests
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-12 18:06 EST by Nicholas Miell
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add DHCPINFORM support to the ifup initscript (413 bytes, patch)
2002-01-12 18:08 EST, Nicholas Miell
no flags Details | Diff

  None (edit)
Description Nicholas Miell 2002-01-12 18:06:39 EST
The DHCP protocol allows clients to make DHCPINFORM requests, which mean
(roughly) "I already have an IP address, but I would like to know all the other
configuration variables."

dhcpcd supports these requests through the "-s" command line option, but the
/etc/sysconfig/network-scripts/ifup script doesn't make use of the option.

Adding support to ifup is easy enough, as the attached patch shows. It only
supports
dhcpcd because (AFAIK), pump can't do DHCPINFORM requests.
Comment 1 Nicholas Miell 2002-01-12 18:08:34 EST
Created attachment 42352 [details]
Add DHCPINFORM support to the ifup initscript
Comment 2 Bill Nottingham 2005-09-29 15:31:37 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Since we don't use dhcpcd any more, closing this.

Note You need to log in before you can comment on or make changes to this bug.