Bug 582850 - Crashes while parsing "Hacker Medley" podcast
Crashes while parsing "Hacker Medley" podcast
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: totem-pl-parser (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 19:35 EDT by Matěj Cepl
Modified: 2010-11-10 16:47 EST (History)
1 user (show)

See Also:
Fixed In Version: totem-pl-parser-2.28.3-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:47:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
one backtrace (54.28 KB, text/plain)
2010-04-15 19:35 EDT, Matěj Cepl
no flags Details
other backtrace (48.37 KB, text/plain)
2010-04-15 19:36 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2010-04-15 19:35:29 EDT
Created attachment 406961 [details]
one backtrace

Description of problem:
Running rhythmbox in the icon and playing podcasts and other long pieces of sound, RB crashes quite often (at least once an hour). Could relate to checking for new podcasts but not 100% sure about it. Certainly explicit checking for new podcasts leads to crash quite often as well.

Version-Release number of selected component (if applicable):
rhythmbox-0.12.6-5.el6.x86_64

How reproducible:
quite often

Steps to Reproduce:
1.play podcast on background
2.
3.
  
Actual results:
RB sometimes crash

Expected results:
it shouldn't, and especially it shouldn't crash when I am doing nothing to it

Additional info:
Comment 1 Matěj Cepl 2010-04-15 19:36:06 EDT
Created attachment 406962 [details]
other backtrace
Comment 3 RHEL Product and Program Management 2010-04-15 20:38:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Bastien Nocera 2010-05-14 10:02:42 EDT
Will fix by rebasing to latest upstream stable version:
http://git.gnome.org/browse/totem-pl-parser/diff/NEWS?h=gnome-2-28&id=654f42f5e85c06c811a9e8f1c948eed3135fd5d8
Comment 6 Tomas Pelka 2010-05-27 10:28:09 EDT
Reproducer in description, giving qa_ack.
Comment 7 Bastien Nocera 2010-06-01 12:33:44 EDT
Fixed in totem-pl-parser-2.28.3-1.el6
Comment 8 Tomas Pelka 2010-06-22 08:13:39 EDT
Matej could you please confirm that this issue is fixed.

Not able to reproduce.

Thanks, Tom.
Comment 9 Matěj Cepl 2010-06-22 15:06:13 EDT
(In reply to comment #8)
> Matej could you please confirm that this issue is fixed.
> 
> Not able to reproduce.

Well, I was able to add http://feeds.feedburner.com/HackerMedley as a new podcast, and download couple of episodes, but of course I wasn't able to test it for longer time. Let's call this bug fixed and I will file a new one if necessary.
Comment 10 Tomas Pelka 2010-06-23 03:07:37 EDT
Perfect Matej, thank you.

Moving to verified.
Comment 11 releng-rhel@redhat.com 2010-11-10 16:47:42 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.